0

today I started to get this issue on my mariadb server

101126 10:29:53 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

Command mysql_upgrade didn't ed because the mysql server was stopped because of the error, so reading around the web I found this command as a possible soluton to the issue

myisamchk –check /var/lib/mysql//.MYI

So I ran it, but now, I'm getting this error:

160818 23:14:51 [ERROR] Unknown/unsupported storage engine: InnoDB
160818 23:14:51 [ERROR] Aborting
160818 23:14:51 [Note] /usr/sbin/mysqld: Shutdown complete

What can I do to get my server up and running again?

Thanks!

Package: mariadb-server (10.0.25-0ubuntu0.16.04.1)
Ubuntu server 16.04 x64
  • The part between it telling you to run a command and you running an entirely different command doesn't make sense, some words missing? You need to run the upgrade to create the missing tables. Myisamchk checks existing tables, it's not going to create a missing one for you... – yoonix Aug 19 '16 at 2:30
  • read first my friend "Command mysql_upgrade didn't worked because the mysql server was stopped because of the error" – razor7 Aug 19 '16 at 3:25
0

Well, It seems to be a package issue, because I restored my server system image to a past time and upgraded everything and mariadb works just fine...so I will report a bug for this, because after upgrade it complaintt this tables missing innodb_index_stats and innodb_table_stats, so I tried mysql_upgrade -uroot -p that failed the first time, then ran it again and said "This installation of MySQL is already upgraded to 10.0.25-MariaDB..." and for the third time with the --force worked ok...really weird!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.