0

Could any one look into the issue and help ?

I have a Red Hat server which has Red Hat subscription and I tried to get all Security patches list using /usr/bin/yum list-security --security. After executing above command, I see all the packages that listed are SuSE packages. Not sure why.

[root@test ~]# /usr/bin/yum list-security --security 
Loaded plugins: rhnplugin, security
slessp3-bash-9740 security bash-3.2-147.20.1.x86_64
slessp3-bash-9780 security bash-3.2-147.22.1.x86_64
Slessp3-binutils-201501-10214 security binutils-2.23.1-0.23.15.x86_64

Tried to verify the yum repository using yum repolist and I see the SuSE repo is enabled. But I didn't see repo file under yum.repos.d to disable.

[root@test ~]# yum repolist 
Loaded plugins: rhnplugin, security
repo id repo name status
rhel-source Red Hat Enterprise Linux 5Server - Source enabled: 5,076
rpmforge RHEL 5Server - RPMforge.net - dag enabled: 11,403
sles11-sp3-pool-x86_64 SLES11-SP3-Pool for x86_64 enabled: 2,862
sles11-sp3-suse-manager-tools-x86_64 SLES11-SP3-SUSE-Manager-Tools x86_64 enabled: 121
sles11-sp3-updates-x86_64 SLES11-SP3-Updates for x86_64 enabled: 3,618
repolist: 23,080

[root@test yum.repos.d]# ls -lrt
total 28
-rw-r--r-- 1 root root 561 Jan 14 2015 rhel-debuginfo.repo
-rw-r--r-- 1 root root 1128 Mar 15 2012 rpmforge.repo
-rw-r--r-- 1 root root 728 Mar 15 2012 mirrors-rpmforge-testing
-rw-r--r-- 1 root root 739 Mar 15 2012 mirrors-rpmforge
-rw-r--r-- 1 root root 222 Sep 17 12:20 rhel-source.repo
1

The clue is in the message: Loaded plugins: rhnplugin

Your RHEL system is either registered with Red Hat for updates, or managed by a RHN Satellite server (or the open source Spacewalk server, SuSe ships it as SuSe manager) through that yum plugin and then you don't need the normal repo configuration files for yum.

0
  1. First off, rpmforge.rpm seems to have turned into repoforge.org according to Google. So your rpmforge.repo may be wonky.

  2. I'd disable it with yum-config-manager --disable rpmforge* (and the same for the mirrors). You can also edit the repo files and set enabled=0 if you want. Perhaps the mirrors are now pointing to SLES?

  3. yum clean all should then get the system to forget about those repos and rebuild things.

  4. I guess you might need to get rid of the SLES plugins too. Instructions to do that are here... https://docs.fedoraproject.org/en-US/Fedora_Core/5/html/Software_Management_Guide/sn-yum-managing-plugins.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.