0

I have a website that sends some email via SMTP and Amazon SES. Any messages that Amazon cannot deliver are sent back to the original from email address, which uses an Exchange 2010 SP3 RU11 server with all roles on a single physical server.

The address that we send the emails from is a 'Customer Support' distribution group, so when they bounce back they are delivered to everyone in the group, which is unproductive. I created an Exchange Transport Rule to redirect these messages to myself. Here is a screen grab of the Exchange Transport Rule

This worked for several weeks, and then the messages started to disappear instead of being delivered. I have Google Apps upstream from my exchange server so I can get some details of the messages like Message-ID which I can then use with Exchange Message tracking. Message tracking indicates that Exchange received the message, and then did nothing with it. Here is the screen grab of the Message Tracking results

Now I'm not an Exchange expert, but I would expect to see the transport rule doing it's thing and redirecting the message. (I'm aware of the 20-30 minute delay that can occur when updating creating a transport rule.) Like I said, it just stopped working all of a sudden and I literally login to exchange like once every couple of months to add/remove employees. After completely disabling the rule, and every other transport rule, waiting overnight, and then having SES send some more bounces my way... Message tracking simply says that it has a RECEIVE event and a RESOLVE event, but no EXPAND or DELIVER.

So it would appear that Exchange is just deleting the message, sort of like trying to deliver a message to a distribution group with no members, but I can't figure out why it happened or what to do to get closer to the reason.

I've tried:

  1. Rebooting
  2. Disabling all transport rules
  3. Deleting all transport rules
  4. Recreating transport rules
  5. Modifying transport rules with different settings
  6. These same things over and over (definition of insanity!)

I know that there are some issues support.microsoft [dot] com/en-us/kb/817220 (Can't post more than two links)with sending NDRs to distribution groups, but I had it set up this way and working and only discovered that MS KB while researching the current problem. I do have ReportToOriginatorEnabled set to true for the distribution group the message are going to.

Is there a possibility that the distribution group itself is corrupt or something? Anyone have any other ideas behind what could be causing the issues?

  • I would setup a pipeline trace, it will tell you more about what is happening to the email as it arrives. technet.microsoft.com/en-us/library/… Create folder on each Hub Transport server: c:\PipeLineTrace. Next run the following PS command: Get-transportserver | set-transportserver -pipelinetracingenabled $true -pipelinetracingsenderaddress user@mail.com -pipelinetracingpath c:\PipelineTrace – smwk Aug 22 '16 at 20:33
0

If I understand correctly your problem, make sure external user can still send to your distribution group.

Properties of the distribution group in the Mail Flow Settings tab under Message Delivery Restrictions.

Make sure Require that all senders are authentified is uncheck.

| improve this answer | |
  • Thanks for the idea @yagmoth555 - External senders make it through, the Message Delivery Restrictions allow unauthenticated senders. – Brian Aug 19 '16 at 23:19
0

Go into the queue viewer and see if those messages are just hanging out in there until they expire.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.