2

I've a NFS share mounted on a Linux (3.16.0-4) Server. The NFS service is marketed as "HA" by the service provided.

Aug 21 05:50:10 srv01 kernel: [2314509.701050] NFS: state manager: check lease failed on NFSv4 server 10.0.0.112 with error 93.

I manually umounted and remounted the share.

What went wrong? Any suggestion ?

1

The error 93 stands for EPROTONOSUPPORT (/usr/include/asm-generic/errno.h) and here is a possible reason for getting that:

NFS server host reboots. The rpcbind server started but they are no entries in it yet. Then nfs service starts and registers v3 and v4 protocols. There is a short time window, where client will ask rpcbind for v4 port, but will get that nfsv4 protocol is not supported, as there only v3 is registered.

Again, this is a possible, but not necessary actual, reason of getting error you have seen.

| improve this answer | |
0

I had a similar problem but with a different error code. I couldn't unmount the filesystem though, I had to reboot.

The problem was that the share was mounted on the client with the (default) hard option, which means that if the server goes away, it will lock the client until the server comes back, so that the client never fails. However when the server came back, it wouldn't allow the client to reuse the old connection. I couldn't remount to get a new connection because trying to unmount would freeze the process. I think this is only designed to handle a network dropout and not a server reboot.

To fix the problem, I edited fstab on the client to add the soft,timeo=15 options to each NFS mount. This means that if the server can't be contacted after 15 seconds, the operation will return an error.

Now, when the server is rebooted, the filesystems all return errors pretty quickly and it's no problem to remount them. In fact, now they seem to reconnect automatically after a server reboot which is even better (possibly because I also have the noauto,x-systemd.automount options so that they only get mounted on first use, instead of at boot time.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.