-6

I'm using Red Hat Enterprise Linux 6.8 on my intra-net machine. While I'm trying to install new rpm, or even curl to some url, I'm getting that output:

rpm: symbol lookup error: /lib64/libnssutil3.so: undefined symbol: PR_GetEnvSecure

Every server that runs on this machine acts as normal. Yesterday I was trying to install git on that machine, and because I'm under intra-net newtork, I've used that script on an internet Fedora machine to download all dependencies and installed everything using:

rpm -ivh --force --no-deps *.rpm

maybe something on the way I installed Git broke everything ... Thanks !

  • 3
    You downloaded Fedora RPM's and forcibly installed those on RHEL 6 and now it's broken. No maybe about it. – HBruijn Aug 25 '16 at 8:45
  • Time to re-install or restore from backup. – HBruijn Aug 25 '16 at 8:45
5

The non-sarcasting and reliable answer would be this.

That script downloaded all dependencies, including a bunch of system libraries. The version of Fedora you used and RHEL 6 are NOT binary compatible.

One way to TRY and repair it would be to figure out which RPMs you overwritten and see if you can replace them with RHEL 6 ones, by first removing the Fedora one and then installing the RHEL one so it doesn't leave extra files. However, repairing this would take quite some time and knowledge. Your best chance would be to restore from a backup, as HBruijn said.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.