1

I was able to connect to my windows systems from linux box using domain credentials, when all of a sudden it stopped working. I have tried different accounts and different domains and getting the same error for every account --

""msg": "kerberos: authGSSClientInit() failed: (('Unspecified GSS failure. Minor code may provide more information', 851968), (\"Can't find client principal user@domain in cache collection\", -1765328243))","

The machine is running ubuntu, running Kerberos 5 version 1.12, and I have rebooted it as well. Klist shows that a valid ticket is available. No changes have been made anywhere. Searched on internet and haven't found anything. How do I find out where the problem is?

These packages are installed:

pip (1.5.4) pycrypto (2.6.1) pykerberos (1.1.13) python-apt (0.9.3.5ubuntu2) python-debian (0.1.21-nmu2ubuntu2) python-ntlm3 (1.0.2) pywinrm (0.2.0)

1
  • After a lot of digging around, I found that there was another cache file in the /tmp folder. I must have done something because of which that file got created. Deleted that file and the problem resolved. Turns out, today again I have the same problem and this time I do not have another cache file. – Aseem Aug 29 '16 at 14:14
1

I had the same issue when I was using the pywinrm library on a linux machine. The solution was to have the domain as upper casing. Example: user@DOMAIN.COM.

I found the solution to my problem here: http://www.slideshare.net/AshwinPawar/krb5

Hope this helps.

0

My problem with the same message was related to a wrong reverse pointer in DNS. I got the idea from Pat Suwalski. I guess a missing DNS pointer could have a similar effect. I just wanted to post this here since the error message is similar.

kerberos: authGSSClientStep() failed: ((''Unspecified GSS failure. Minor code may provide more information'', 851968), (''Server not found in Kerberos database'', -1765328377))

The Ansible documentation related to Windows changed for the better in recent years:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.