4

Recently I needed to create a new VM, and this VM needed to start from ISO file. When I mounted an ISO file and tried to boot, I’ve seen the following error:

Synthetic SCSI Controller (Instance ID xxx): Failed to Power on with Error ‘The version does not support this version of the file format’

  • Consider starting from IDE. – TomTom Aug 28 '16 at 16:52
3

Your ISO file is most probably blocked by Windows.

Start by right-clicking the file => Properties. Click Unblock => OK/Apply.

Try now, and if that doesn't work, create a copy of the ISO file and try again.

If that doesn't work, Try a different machine.

2

The solution to this problem is very simple: just make a copy of the ISO file and use that instead!

The issue is that Hyper-V does not support booting from sparse ISO files. A file may be sparse if it was downloaded via BitTorrent or other parallel download managers. A regular Windows Explorer file copy will create a non-sparse copy, which Hyper-V supports.


To check whether or not a file is sparse, Right Click, select Properties, and look at the Details tab. If P is present under the Attributes, the file is sparse and will fail to boot:

Screenshot of Details tab with Attributes section highlighted

  • Thank You! I made copy and then file "Properties" -> "Unblock", and it worked! File wasn't "AP" but "AI", but ctrl+c, ctrl+v helped, Thank You!! – Gennady G Aug 16 '18 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.