-3

I set the name server records of my domain name around 48 hours back, and the domain name is still not getting propagated. I checked on

https://www.whatsmydns.net/

and I could see that only around 2-3 of the 20 odd DNS servers shown on the map there were returning proper domain records as set by me. So the records are getting updated only partially.

I was wondering who is to blame for this slow propagation, the folks from whom I purchased my domain name, or is it generally that the caches are still not refreshed.

I have several domain names, and the typical time taken for this 4-5 hours; this is the first time that it's taking so long for the DNS updation.

  • It's too bad that you didn't include the actual domain name so that we could provide answers. As it is your question will probably be closed because it isn't answerable. – joeqwerty Aug 29 '16 at 16:50
  • Oops! My bad. It's aaishazkitchen.com. – Najeeb Aug 29 '16 at 16:50
  • @joeqwerty, updated the question – Najeeb Aug 29 '16 at 16:53
3

You problem here is that those NS's are not returning your dns records. Make sure that you have dns zone with relevant RR records active on NS49.DOMAINCONTROL.COM/NS50.DOMAINCONTROL.COM

As for how fast your registrar would update NS's on root servers, that depends on where are you changing NS's. Do you send ticket to your registrar or do you change them directly on their interface. You can check whois service of your choice after you change NS's to see if change took place immediately or if there is delay.

| improve this answer | |
  • I changed the name servers myself. A query though, if the name servers are not returning any records, how come the records are getting updated partially worldwide? – Najeeb Aug 29 '16 at 17:13
  • 2
    @Najeeb whatsmydns.net/#A/aaishazkitchen.com is returning no records, anywhere worldwide. Maybe you had it working and then broke it later on? – ceejayoz Aug 29 '16 at 17:31
  • @ceejayoz, the nameserver records are gettingreturned though only partially: whatsmydns.net/#NS/aaishazkitchen.com. – Najeeb Aug 30 '16 at 3:31
  • @Najeeb you didn't create dns zone with records you need. Those servers that are being used for dns queries are returning RR of your choice (ns, a, cname..) but without active dns zone for your domain, they can't show anything. – RonanW. Aug 30 '16 at 4:42
  • 1
    Correct, right now you've set NameServers and they should hold your DNS zone. If you have hosting somewhere, you should have IP address of your hosting server. Log to your account connected to your NS's, create DNS zone, add or use existing records to point them to your hosting server and after a while, you'll get response when doing dns queries. – RonanW. Aug 30 '16 at 9:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.