0

Over the past few days, an error seems to have developed on my Windows 10 Professional (anniversary update) workstation, whereby when opening the Update section of the Modern Settings app, loads of services instantly crash.

NOTE: No updates were installed over the weekend, and I have made no changes within the past week or two.

It seems that opening the update page within settings, it causes the Windows Update service to crash with (Faulting application name: svchost.exe_wuauserv) a faulting DLL of ntdll.dll, exception code: 0xc0000409. This is an "Application Error" event, event ID 1000.

Immediately after this, the following services also terminate unexpectedly (Service Control manager events, ID 7034, 7031):

  • Application Information Service
  • Computer Browser
  • Certificate Propogation
  • Group Policy Client
  • IKE and AuthIP Keying Modules
  • IP Helper Service
  • Server Service
  • Geolocation Service
  • User Profile Service
  • System event notification
  • Remote desktop configuration
  • Shell hardware detection
  • Themes
  • User manager
  • Update Orchestrator for Windows Update
  • Windows management instrumentation

I have run SFC /Scannow, which reports corruption was found and repaired. If I run it again straight away, it returns the same response. I am not really sure what to look for in the CBS.log file, but there doesn't appear to be anything too major, other than some directory ownership mismatches.

I have run DISM with the scanhealth and restorehealth switches, both of which complete successfully without errors. Ran SFC again and the same corruption message.

I have tried downloading the Windows 10 ISO, and doing an in place "Upgrade", but the same issue exists.

Is there anything else I can try without having to wipe the machine and start over? Being my workstation, there are a lot of management applications on here that I don't really want to have to set up again from scratch. (System restore not available as for some reason it is disabled by default in Windows 10?!).

3

I've had a similar problem with Windows Update on two Windows 10 computers. I think I've fixed it on one computer. Windows Update is working again and the relevant error messages are not appearing in the Windows logs.

However there are a raft of other problems seemingly caused by the anniversary update, including problems with Task Scheduler, the Start Menu, and Azure Recovery Services agent.

These are the steps I took to get Windows Update working:

  1. Fix two event ID 10016 DCOM errors.

  2. Install the missing Windows Updates manually, using the Microsoft Update Catalog to download stand-alone packages. These are: KB3176929 (Aug 2, 2016), KB3176495 (Aug 9, 2016), and KB3176934 (Aug 23, 2016). See this Microsoft Support article: https://support.microsoft.com/en-us/help/12387/windows-10-update-history

  3. Run SFC and DISM, but I don't think they helped. No errors were reported.

  4. Disable OneSyncSvc using Task Manager.

  5. Uninstall Bonjour.

  6. Windows Update then obligingly installed a few more updates including KB3176934.

I hope this helps, however I'm sorry I can't say for definite which step fixed the problem.

UPDATE: Windows Update is working on the second computer now. I discovered one more 10016 error, fixed it, and restarted the computer.

This is the message in the system event log and the name of the component in Component Services is RuntimeBroker.

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

This article explains how to fix 10016 errors: http://www.eightforums.com/performance-maintenance/11951-numerous-event-id-10016-errors-win-8-pro-64-bit.html

  • Thanks for your reply. I can't recall if I had any 10016 DCOM errors to be honest, so not sure if my scenario was the same. I ended up just rebuilding the machine, as I needed to continue with the many jobs I was in the middle of. Glad you got yours sorted. – James Edmonds Sep 1 '16 at 11:08
  • Well frustratingly, after having reinstalled Windows from scratch, these service crashes have returned in the exact same fashion. I am going to check your link for info on fixing the DCOM errors, as I have exactly the same error you mentioned in your edit. – James Edmonds Sep 2 '16 at 8:26
  • Well, I installed the missing update: support.microsoft.com/en-us/kb/3176938 and it seems to have fixed the problem so far touch wood – James Edmonds Sep 2 '16 at 9:38
  • Yes, my third computer had been clean installed on 3rd August with version 1607, and this experienced the same problems. I'm still touching wood... – RichardCL Sep 4 '16 at 14:54
  • Redmond Magazine: Windows 10 Update KB3176934 Breaks PowerShell -- redmondmag.com/articles/2016/08/25/… – RichardCL Sep 4 '16 at 14:55
0

I came up with my own solution for the same issues as described above. I will also document some of the attempted fixes initially.

Attempts:

1) Restart windows update service
2) Disable windows update service, clear c:\windows\softwaredistribution\downloads
3) Reboot machine with combinations of the above
4) Manual installations from the update library - not effective whatsoever.
5) dism /online /cleanup-image /scanhealth (and restorehealth)

Final fix (where the machine is currently rebooting after installing about 30 updates, including the oct 27 2016 1607 cumulative update)

Ran disk cleanup utility. Hit button for cleanup system files. Check off all boxes. Remove all files. Reboot. Run windows update, click 'check online for updates from microsoft' (NB: I had synchronized and approved all updates on WSUS internally yesterday). It did the usual crunch time, followed by installs, then some weird logs that I didn't want to dive into. Prompted for a reboot from windows update. Appears successful will edit post if it failed.

Edit:

Had to resolve the same issue on another computer. Steps solidified:

1) note the inherent issue in syslogs
2) Stop the windows update service
3) Set the update service to disabled
4) Clear the \softwaredistribution\downloads folder
5) Run the disk cleanup utility, hit the clean system files button, check off anything and everything I am willing to nuke
6) REboot
7) enable the WU service
8) Open up windows update, tell the machine to check online (because I normally use WSUS)
9) watch the update carefully in task man to ensure that it's getting the updates online instead of from WSUS
10) machine successfully updated, reboot.

0

I was fighting to fix this annoying issue on my work machine. I have tried RichardCL's solution + all comments and browningit's steps to no avail.

What actually fixed the problem for me was installing all cumulative updates listed for Windows 10 1607 on Windows 10 and Windows Server 2016 update history page. Notably the updates that I have manually installed are (in the listed order):

  • KB3176929
  • KB3176495
  • KB3176934
  • KB3176938
  • KB3193494
  • KB3200970
  • KB3194798
  • KB3197954
  • KB3206632
  • KB3201845
  • KB3213986

I have downloaded them from Microsoft Update Catalog site. You don't need to reboot after each update. Reboot at the the end is sufficient.

0

We had the same issue in a corporate environment. Once we summited Windows 10 build 1607 to the WSUS server, the eventlog became red, Service Control Manager events 7031, 7032 and 7034.

Apparently the windows update mechanism in build 1607 is broken, and we had to;

  1. Manually download and install patch; windows10.0-kb3216755 from https://catalog.update.microsoft.com
  2. Reboot windows 10
  3. After this, Windows 10 could normally update from WSUS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.