1

I am running an instance on gcloud compute engine. I need to mount a Google storage bucket (which belongs to a different project) to my instance. The instance runs on Debian Wheezy. I have installed gcc, fuse, gcsfuse. But when I tried to mount the bucket:

$ gcsfuse bucket-name /mnt/bucket-name

I got the error: stderr: fusermount: fuse device not found, try 'modprobe fuse' first

Tried "modprobe fuse", I got error: -bash: modprobe: command not found

Anyone knows what the problem might be, or anyone has encountered the same issue? Any thoughts, comments, help would be much appreciated. Thanks in advance!

1

I have resolved the issue with an upgrade to Jessie and then installed gcsfuse following the instructions here: https://github.com/GoogleCloudPlatform/gcsfuse/blob/master/docs/installing.md

  • That is actually a poor suggestion to a simple problem of finding a system command. – Julie Pelletier Sep 1 '16 at 6:10
1

To locate a command on your system, you can use whereis which will search all the common locations to give you the full path.

whereis modprobe

.. on my system outputs:

modprobe: /sbin/modprobe /etc/modprobe.d /etc/modprobe.conf /lib/modprobe.d /usr/share/man/man8/modprobe.8.bz2

In this case, and probably yours, you would then know to call it as /sbin/modprobe fuse.

  • 1
    Have tried that, but it wasn't there. – user3175643 Sep 2 '16 at 14:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.