1

I succesfully installed Graphite by this tutorial:

https://www.digitalocean.com/community/tutorials/how-to-install-and-use-graphite-on-an-ubuntu-14-04-server

and when I run:

echo "test.count 4 `date +%s`" | nc -q0 127.0.0.1 2003

and run: whisper-fetch /var/lib/graphite/whisper/test/count.wsp

the value 4 appears to be saved

but when I run the same command later from another computer and I change localhost to my ip address:

echo "test.count 4 `date +%s`" | nc -q0 192.168.88.65 2003

the value appears not to be saved in whisper after all.

But when I delete the directory:

/var/lib/graphite/whisper/test

and run previous command again, so the test folder will be created but without saving the value there.

Does anybody know how can I send the metrics to whisper from another computer in the same network?

I know the port is open because nmap returns:

martin at martin-pc templates >>> nmap 192.168.88.65

Starting Nmap 7.01 ( https://nmap.org ) at 2016-09-01 18:25 CEST
Nmap scan report for 192.168.88.65
Host is up (0.0033s latency).
Not shown: 993 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
80/tcp   open  http
111/tcp  open  rpcbind
2003/tcp open  finger
2004/tcp open  mailbox
3000/tcp open  ppp
7002/tcp open  afs3-prserver

I think that it will probably be something in config (maybe the security policy) but I don't know what exactly.

UPDATE: I don't know why, but when I rebooted computer so now it is all working ..

0

Graphite has no security policies for port 2003, if it's listening on port 2003 - it will accept metrics there.

1
  • I rebooted computer and now it is working.. tkanks for your response :)
    – mjablecnik
    Sep 2 '16 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.