0

I have a Cisco 2911 router. I am able to login via SSH with normal user accounts. (However, of interest is that I was just recently unable to login using the password of one user until I re-entered the 'user' statement to the configuration at which point it started working again.)

I setup an SSH key for the user it worked fhor a while - and just like the comment above regarding being unable to login with my user password until I re-entered the user configuration directive. However, now I cannot use the key to login nor has re-entering the key directive worked. I tried entering the public key on the command line to let the Cisco generate the fingerprint as well as enter the fingerprint directly without success. According to the Cisco logs, the login fails.

On my computer, I try to logon via SSH like so. This process has worked to logon to the SSH server on the Cisco router in question at "c2911-1.lan" numerous times, and is pretty straight-forward.:

brendan@MB-Pro:~$ ssh -oPubkeyAuthentication=yes -i .ssh/cisco1.rsa brendan@c2911-1.lan Enter passphrase for key '.ssh/cisco1.rsa': Disconnected from c2911-1.lan

The logs from the Cisco router in question:

Sep 1 13:53:31.275: %SSH-5-SSH2_SESSION: SSH2 Session request from 10.201.50.39 (tty = 1) using crypto cipher 'aes128-cbc', hmac 'hmac-sha1' Succeeded Sep 1 13:53:36.335: %SSH-5-SSH2_USERAUTH: User 'brendan' authentication for SSH2 Session from 10.201.50.39 (tty = 1) using crypto cipher 'aes128-cbc', hmac 'hmac-sha1' Failed Sep 1 13:53:36.335: %SSH-5-SSH2_CLOSE: SSH2 Session from 10.201.50.39 (tty = 1) for user 'brendan' using crypto cipher 'aes128-cbc', hmac 'hmac-sha1' closed

I have the proper key fingerprint stored. My SSH client is presenting the proper key. Is there something I'm missing?

  • You missed Enter passphrase for key '.ssh/cisco1.rsa': – Michael Hampton Sep 4 '16 at 3:17
  • That's obviously just something I didn't paste here. You wouldn't see the output anyway. I did enter my passphrase, and it was correct, that's why I was immediately disconnected afterwards instead of SSH prompting me to re-enter my passphrase. If I had used an incorrect passphrase it would ask me for it again. Like I said in the question, even though the passphrase is correct and the fingerprint in the ssh config on the cisco router is correct, it's just disconnecting me immediately after entering it and claiming auth failed. No idea why ... – Brendan Sep 4 '16 at 4:19
  • Can you post the relevant parts of your cisco configuration? – Mark Riddell Sep 4 '16 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.