0

I have Microsoft Windows server 2008 R2 and have the IIS 7 running.

I have coded a web application on a seperate laptop and would like to publish it now on my server (serves as AD, DNS, File Server, IIS) that runs locally and has no external access. We will be using the application internally only.

I have followed the steps to install a website on IIS, however, it does not work. Below are the steps I have done.

  • Created a folder hierarchy and pasted the code files there. (check below image. The code files are inside wwwroot)

[![enter image description here][1]][1]

  • Create a new website from the IIS Manager as the below image.

[![enter image description here][1]][1]

  • The wwwroot folder has SYSTEM permission and it inherits the permissions from the parent. (Does it need to have other permissions?!?)

    • Whenever I visit the website, I get an error that the page is not found.

update

Upon the answer below, I have tried his steps as the below image, but the username is not found and the error persists.

[error][2]

After other suggestions, still getting errors :/

error 1 error 2 Any ideas what is wrong?

1
  • Depending on what the application is written in, it could be an issue with a missing handler. E.g. if the application is written in ASP.NET you will have to make sure that ASP.NET is installed and enabled in the IIS. It could also mis-configured default document setting on IIS. – Lars Lind Nilsson Sep 6 '16 at 10:04
0

First - make sure you have network access to the server - from your description it is not clear how you are trying to contact the server. The basic check is to try to browse the site through IIS Manager from the server itself.

Next - be sure that the application pool identity has permissions over the file system (on the folder with the website). Explanation - The application pool mySite.local is running under some identity (default is ApplicationPoolIdentity but you can assign there any user you would like). This identity has to have read/write (based on what you website is doing, but at least read) permissions to the folder where the website is located.

BR, JaSo

9
  • I still cannot connect to the site even when I try to get there from the IIS manager. Your second point makes a lot of sense. Can you please guide me more what can I do regarding that? – James Ronaldo Sep 6 '16 at 13:40
  • Sure - the Application Pool is running under some user (Identity) - you can see it in Application Pools there is a column named Identity in the list (also you can change it by rclick-> Advanced Settings -> Identity and click on three dots-> Select Custom account -> Set and type credentials for user you would like to run the Application Pool). – JaSo Sep 7 '16 at 9:57
  • Next check the folder C:\domains\mySite.local - rclick -> Properties -> Security tab. There has to be the identity which is running the App Pool mySite.local. If the App pool mySite.local is running under ApplicationPoolIdentity then you have to Edit the Security list - Edit -> Add (if your server is in domain change location to your server) and add IIS APPPOOL\DefaultAppPool (this is the ApplicationPoolIdentity), give it Modify permissions and try if it helps. – JaSo Sep 7 '16 at 9:57
  • thanks a lot for your feedback. I tried and getting this error where the DefaultAppPool is not present in the usernames. any ideas ? thanks a lot. – – James Ronaldo Sep 7 '16 at 13:00
  • That is why I typed this information - (if your server is in domain change location to your server) :). basically you have to change the location where you are searching. In the text field "From this location:" there mustn't be the domain, but there has to be the hostname of the server - click on Locations and scroll up. Hostname should be the first on the list. Select it and you will be searching for the DefaultAppPool locally on the server instead of domain. – JaSo Sep 7 '16 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.