1

I am configuring multiple (named) instances of SQL Server 2016 on my Windows Server 2012 Azure VM. I have LogMeIn Hamachi installed on this VM and my own computer for a secure connection between the two.

I can connect to my default SQL instance by just using the IP in my SQL Server Management Studio, but connecting to my named instanced just doesn't work.

  • I set the port to 1435 in Sql server config manager for all IP's
  • I tried using the VM IP + "\instancename" and ip + ":1435"
  • I tried using the Hamachi IP + "\instancename" and ip + ":1435"

I have Sql management studio installed on that specific VM and I can login to the named instance using the internal IP\instancename and also machinename\instance, but any attempt to connect remotely fails.

  • Its all going to come down to DNS. Can you ping the server by name while connected via Hamachi? – DanBig Sep 6 '16 at 14:18
  • I can't but I can't do it either if I don't use hamachi (direct IP of the VM). Keep in mind RDP works fine both direct and via hamachi, so does connecting with sql management studio via direct and hamachi. It's just the ip\namedinstance that doesn't work. – user2713516 Sep 7 '16 at 6:55
2

Each instance should run on its own port and as long as the SQL browser (port 1434) is running you should be able to access the individual instances using "HOST_NAME\INSTANCE_NAME". If you need to use the IP address the you should be able to reference these using "IP,PORT", notice the comma instead of a colon.

| improve this answer | |
  • 2
    This is wrong: "Each instance should run on its own IP" – longneck Sep 13 '16 at 18:59
  • 1
    Corrected, meant port. – Jason Cumberland Sep 14 '16 at 4:47
  • sorry for the late reply, but using the ip,port setup doesn't work either, all the default solutions work when connecting from within the VM, but when connecting from outside Azure it all fails again. – user2713516 Sep 26 '16 at 7:17
  • Can you telnet to the IP on your SQL port and get the blank screen? If not then you've probably got a firewall port to be opened. – Jason Cumberland Sep 26 '16 at 13:36
  • Using telnet I indeed ran into the fact that access was still blocked, even though I set my Azure firewall correctly. Then I realised that I still needed to configure the windows firewall as well...after I did that, and configured the static port numbers for each instance I managed to connect using the IP,PORT syntax. Thanks :) – user2713516 Sep 29 '16 at 10:21
0

This may seem kind of silly, but try adding the remote computer's name to the hosts file with the ip over hamachi and then try using it as though you were directly connected. (e.g. on the same LAN)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.