-1

the command

yum updateinfo list

running well on redhat 6 and 7 as the following

  yum updateinfo list
  Loaded plugins: product-id, rhnplugin, subscription-manager
  This system is receiving updates from RHN Classic or Red Hat Satellite.
  RHEA-2015:2461 enhancement Red_Hat_Enterprise_Linux-Release_Notes-7-en-US-      7-2.el7.noarch
  RHBA-2015:2371 bugfix      alsa-tools-firmware-1.0.28-2.el7.x86_64
  RHBA-2015:2403 bugfix      authconfig-6.2.8-10.el7.x86_64
  RHBA-2015:2144 bugfix      bash-4.2.46-19.el7.x86_64

but on redhat 5.X

I get the following results because updateinfo not defined on redhat 5

  #  yum updateinfo list
  Loaded plugins: rhnplugin, security
  This system is receiving updates from RHN Classic or RHN Satellite.
  usage: yum [options] COMMAND

  List of Commands:

  check-update   Check for available package updates
  clean          Remove cached data
  deplist        List a package's dependencies
  downgrade      downgrade a package
  erase          Remove a package or packages from your system
  groupinfo      Display details about a package group
  groupinstall   Install the packages in a group on your system

2 Answers 2

1

The yum updateinfo option was added to the Yum security plugin for RHEL6.

If you are using RHEL5, you can use yum list updates --security (you need to install yum-security)

You asked "why?"

It's because you provided an invalid option for your RHEL5 system, so the command prints its usage parameters instead of doing anything.

3
  • is it possible to view the errata as I did it on redhat 6 or 7 ?
    – dandan
    Commented Sep 7, 2016 at 14:38
  • @dandan Yes. I wrote: "If you are using RHEL5, you can use yum list updates --security"
    – ewwhite
    Commented Sep 7, 2016 at 14:40
  • yes but your command not display the errata numbers , see my answer
    – dandan
    Commented Sep 7, 2016 at 14:43
1

the command for redhat 5 is:

yum list-sec
  • To list all available erratas without installing them

for example:

 yum list-sec
 Loaded plugins: rhnplugin, security
 This system is receiving updates from RHN Classic or RHN Satellite.
 RHBA-2014:1368 bugfix   at-3.1.8-84.el5_11.1.i386
 RHBA-2014:1209 bugfix   cpp-4.1.2-55.el5.i386
 RHBA-2015:0064 bugfix   cups-1:1.3.7-32.el5_11.i386
 RHBA-2015:0064 bugfix   cups-libs-1:1.3.7-32.el5_11.i386
 RHBA-2014:1868 bugfix   device-mapper-1.02.67-2.el5_11.1.i386
 RHBA-2014:1868 bugfix   device-mapper-event-1.02.67-2.el5_11.1.i386
 RHBA-2014:1228 bugfix   device-mapper-multipath-0.4.7-63.el5.i386

.
.
.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .