0

My customer has a domain with a number of workstations. Some of these workstations have USB printers attached.

They have a server (2008 R2) that is on a workgroup outside of the domain which the users connect to in order to use legacy software.

Previously these USB printers were locally mapped on the server which is required as the software they use doesn't recognize the clients printers. The customer then had an issue with a virus which caused all the mappings to be disabled.

I have been unable to get the printer mappings to return. I can map and print to them as network printers fine but if I try to add them as local printers over TCP/IP they fail. Nothing appears in the event logs at either end when I try to map the printers.

I have tried temporarily disabling antivirus and setting up a file share on the printer hosts then connecting to it with valid domain credentials before mapping the printer to eliminate the most common causes with no luck.

At this stage I think the answer is to just purchase network printers to replace the USB printers or attach the workgroup server to the domain, but nobody knows why it's off the domain and are too afraid to attach it in case it breaks something else. Also it worked previously so surely there is an actual solution.

0

OK I found the answer here and have confirmed it worked for me: User cannot access shared printer in Windows Server 2003

I've modified the answer below for windows 7/8/10

  • Install LPD Print Service (found under Print and Document Services) in Windows features.

  • Verify that the Windows Firewall on the machine permits inbound connections from the Terminal Server on TCP port 515.

  • Add the printer to the Terminal Server as a local printer attached to a "Standard TCP/IP Port" referring to the name or IP address of the Windows PC. There will be a long delay while Windows attempts to "detect" the port. When you finally get the dialog with a drop-down list of port types choose "Custom", click "Settings" and modify the default properties to use the "LPR" protocol, set the "Queue Name" to the "Share Name" of the printer on the Windows XP machine, and tick the "LPR Byte Counting Enabled" box. (This selection has nothing to do with the printer model-- this is just to get LPR going between the boxes.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.