0

I have a working installation of BackupPC and I try to add a host, that is only reachable through a different host. For this reason, I created a ssh config file and reaching the host via rsync or ssh is no problem.

But now I can't start a Backup because BackupPC tries to ping the host before starting the backup. The strange thing is, that the ping command and the NmbLookup command for that host are set to /bin/echo. I have also tried to use /bin/true but this did also not succeed.

So I don't know what I could try next.

Thanks for any Help

1

My problem is solved. I tried it the different way round:

  • I added a ClientNameAlias with the value 127.0.0.1 so that the ping succeeds
  • Then i tried to override the client rsync options to the name in the ssh config

Now backuppc connects to the remote host and the ping command succeeds.

0

I just solved this problem by manually editing the /etc/hosts file on the BackupPC server. Nothing made sense. I could ping the host from the BackupPC server just fine and other backups using identical settings were working perfectly. I first tried using the PC's IP address instead of the hostname. That got past the ping and seemed to work but there were were other problems: (tree connect failed: NT_STATUS_BAD_NETWORK_NAME)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.