0

We've just installed a new installation of Exchange 2016 that we will eventually migrate our Exchange 2010 users over to.

Before doing that, I ran the BPA and it reported some warnings about various server health entries. One of these was the Monitoring HealthSet:

[PS] C:\>get-healthreport server01 -healthset monitoring

Server    State          HealthSet   AlertValue  LastTransitionTime   MonitorCount
------    -----          ---------   ----------  ------------------   ------------
server01  NotApplicable  Monitoring  Unhealthy   08/09/2016 2:39:...  29

Checking the entries, I see that HealthManagerWorkItemQuarantineMonitor is marked as Unhealthy:

[PS] C:\>get-serverhealth server01 -healthset monitoring | select name,alertvalue

Name                                                AlertValue
----                                                ----------
CrimsonMonitor                                         Healthy
EDSServiceRunningMonitor                               Healthy
EDSJobPoisonedMonitor                                  Healthy
SqlOutputStreamInRetryMonitor                          Healthy
ServerHealthStateCollectionMonitor                     Healthy
HealthManagerWorkItemQuarantineMonitor               Unhealthy
MaintenanceFailureMonitor.Monitoring                   Healthy
MaintenanceTimeoutMonitor.Monitoring                   Healthy
HealthManagerSchedulingLatencyMonitor                  Healthy
PrivateWorkingSetWarning.M.E.diagnostics.service       Healthy
PrivateWorkingSetError.M.E.diagnostics.service         Healthy
ProcessProcessorTimeWarning....iagnostics.service      Healthy
ProcessProcessorTimeError.M.E.diagnostics.service      Healthy
CrashEvent.M.E.diagnostics.service                     Healthy
PrivateWorkingSetWarning.M.exchange.monitoring         Healthy
PrivateWorkingSetError.M.exchange.monitoring           Healthy
ProcessProcessorTimeWarning.M.exchange.monitoring      Healthy
ProcessProcessorTimeError.M.exchange.monitoring        Healthy
CrashEvent.M.exchange.monitoring                       Healthy
PrivateWorkingSetWarning.msexchangehmhost              Healthy
PrivateWorkingSetError.msexchangehmhost                Healthy
ProcessProcessorTimeWarning.msexchangehmhost           Healthy
ProcessProcessorTimeError.msexchangehmhost             Healthy
CrashEvent.msexchangehmhost                            Healthy
PrivateWorkingSetWarning.msexchangehmworker            Healthy
PrivateWorkingSetError.msexchangehmworker              Healthy
ProcessProcessorTimeWarning.msexchangehmworker         Healthy
ProcessProcessorTimeError.msexchangehmworker           Healthy
CrashEvent.msexchangehmworker                          Healthy

I can't find any information about what HealthManagerWorkItemQuarantineMonitor is or how to troubleshoot it.

If I run invoke-monitoringprobe monitoring\HealthManagerWorkItemQuarantineMonitor -server server01 I get the following:

WARNING: Could not find assembly or object type associated with monitor identity
'monitoring\HealthManagerWorkItemQuarantineMonitor'. Please ensure that the given
monitor identity exists on the server.

What can I check for this?

1

I'm having the exact same issue.

I ended up searching my logs and found a reference to the HealthManagerWorkItemQuarantineMonitor in Microsoft\Exchange\ManagedAvailability\Monitoring:

Workitem "E4eException.Maintenance.WorkItem" (ID: 37) repeatedly caused
Exchange Health Manager worker process to restart. As a result it has 
been quarantined and will not be scheduled to run for 24 hours.

-------------------------------------------------------------------------------

States of all monitors within the health set:
Note: Data may be stale. To get current data, run: Get-ServerHealth -Identity '<SERVERNAME>' -HealthSet 'E4E'

I've recently had an issue with the DAG that this server is in and had been working on it. So for me, I'm going to check it again tomorrow and check the health status again.

Hope this is somewhat useful.

  • Well, mine seems to have resolved itself on its own. While I didn't see the same event message you did, you did point me to where I could at least find these messages, so thanks! – Caynadian Sep 14 '16 at 14:37
0

You're trying to invoke a monitor. You need to invoke the probe associated with that monitor. In your case:
Invoke-MonitoringProbe Monitoring\HealthManagerHeartbeatProbe -Server server01

You can find probes by running:
Get-MonitoringItemIdentity <HEALTHSET> -Server server01 | ? {$_.ItemType -eq 'Probe'} | ft name,itemtype -auto

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.