• Postfix 3.1.2
  • CentOS 6.8
  • Kernel and CPU Linux 2.6.32-642.4.2.el6.centos.plus.x86_64 on x86_64
  • Dovecot, PostGrey, Amavis

After start postfix it give warning message.

[root@sun etc]# postfix start
postfix/postfix-script: warning: group or other writable: /etc/postfix/./master.cf
postfix/postfix-script: starting the Postfix mail system

Update 1:

I found the reason. It give the error cause master.cf file refer symlinking file. If I gave 777 it give the warning. If I gave 644 then permission denied error.

  • It's not clear what your question is. That warning seems pretty clear. Have you checked the permissions on that file? – Paul Haldane Sep 10 '16 at 12:37
  • @PaulHaldane I checked the permision file and folders. I gave chmod and chown command but this It give this warning message – RedLEON Sep 11 '16 at 9:05
  • A quick test for me shows that this has to be related to the permissions on that file (I tried with Postfix 2.x on CentOS 7 but assume this should be reasonably consistent). Show us the output from ls -l /etc/postfix/master.cf and getfacl /etc/postfix/master.cf`. – Paul Haldane Sep 11 '16 at 12:08

There is a bug in the postfix permissions-checking program. It checks the permissions of symbolic links instead of the permissions of the targets of the links. Of course symlink permissions are always 777 and postfix incorrectly complains about that. I tried fixing /etc/postfix/postfix-script by adding ! -type l to all the relevant find commands, but that didn't fix it. One might have to fix and then recompile the postfix command itself. You could replace the symlinks with hard links, but that might have unintended consequences at upgrade time.


A chmod 644 /etc/postfix/main.cf should fix that.

  • I just tried after then same result: postfix/postfix-script[30477]: warning: group or other writable: /etc/postfix/./master.cf – RedLEON Sep 11 '16 at 9:10
  • Please execute the following commands: postfix stop ; chmod 644 /etc/postfix/master.cf ; /etc/init.d/postfix start ; ls -l /etc/postfix/master.cf Tell us, what the permissions for the file now are. And is there a special reason, why you execute the postfix binary directly instead of using the start/stop script? – Stefan Guenther Sep 11 '16 at 15:20
  • So sorry the reason is my blind eyes. I found the reason. It give the error cause master.ff file refer symlinking file. If I gave 777 it give the warning. If I gave 644 then permission denied error. @Stefan Guenther – RedLEON Sep 15 '16 at 20:17

Might be worth adding why postfix utters this warning.

If postfix's configuration file is writable by ordinary users on your box, they could easily reconfigure it to e.g. 'steal' another user's mail or just mess things up - simply by changing master.cf.

It would be pretty much impossible to tell who did it and what changed, so postfix kindly advises you to make sure you fix the permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.