7

I've followed the instructions at https://certbot.eff.org/all-instructions/#debian-8-jessie-nginx but cannot install certbot:

sudo apt-get -t jessie-backports install certbot

Reading package lists... Done E: The value 'jessie-backports' is invalid for APT::Default-Release as such a release is not available in the sources

Hints appreciated

3
  • Using the instructions for OS releases without a package since that is probably the only thing I can do in this situation.
    – Sue Spence
    Sep 12, 2016 at 13:00
  • 1
    Same issue here. Went off of backports.debian.org/Instructions/#index2h2: deb http://ftp.debian.org/debian jessie-backports main. Ran aptitude install python-certbot-apache -t jessie-backports after adding to /etc/apt/sources.list. Got E: The value 'jessie-backports' is invalid for APT::Default-Release as such a release is not available in the sources printed twice. Sep 12, 2016 at 13:26
  • Please run "apt-get update" after changing the sources list and before installing the package.
    – Lupold
    Nov 7, 2016 at 10:24

5 Answers 5

7

did you follow instructions above that to enable backports? You need to add

deb http://ftp.debian.org/debian jessie-backports main

to your /etc/apt/sources.list

5
  • 1
    The error message on my end quoted above was the same after adding the line you mentioned. I don't think the problem is on Sue's end. Sep 12, 2016 at 13:27
  • 2
    I couldn't comment below the main post. Thought I would try the obvious. Sep 12, 2016 at 13:33
  • Fair enough. Maybe others will bring up a different fix. Sep 12, 2016 at 18:08
  • I had enabled backports, so that isn't the answer.
    – Sue Spence
    Sep 13, 2016 at 12:29
  • Yes I did that . and apt-get update I get this error
    – chrips
    Nov 3, 2018 at 15:34
3

Had the error message above. Running apt-get update (per the instructions) after adding the jessie-backports repository solved the problem for me

2

If you are using Digital Ocean, they replace the APT sources with their own mirror. You can add backports support by adding this to your /etc/apt/sources.list

deb http://mirrors.digitalocean.com/debian jessie-backports main
deb-src http://mirrors.digitalocean.com/debian jessie-backports main
1

Add this to your /etc/apt/source.list

deb http://mirrors.digitalocean.com/debian jessie-backports main
deb-src http://mirrors.digitalocean.com/debian jessie-backports main

run apt-get update after that run

sudo apt-get install python-certbot-apache -t stretch

simple change sudo stretch-backports to stretch

-1

Add this to your /etc/apt/source.list

deb http://mirrors.digitalocean.com/debian stretch main

I am running this in a docker and jessie-backports no longer exists, and stretch-backports does not contain the files. They have been moved to stretch

1
  • Jessie is still in LTS. Why should someone upgrade to stretch? Apr 19, 2019 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.