1

To register dns we run ipconfig /registerdns, as I understand the user should have Administrative privileges to run the above command in an elevated prompt.

So when I run registerdns with LocalAdmin account it works fine but when I run it with Domain Admin account I get an error in eventviewer like this

The system failed to register pointer (PTR) resource records (RRs) for network adapter with settings:

       Adapter Name : {D88CE795-6AB7-4710-A713-C62523177973}
       Host Name : XXXXXXXXXXXXXX
       Adapter-specific Domain Suffix : XXXXXXXXX.com
       DNS server list :
            xxx.xxx.xxx.xxx, xxx.xxx.xxx.xxx
       Sent update to server : <?>
       IP Address :
         yyy.yyy.yyy.yyy

The reason that the system could not register these RRs was because of a security related problem. The cause of this could be (a) your computer does not have permissions to register and update the specific DNS domain name set for this adapter, or (b) there might have been a problem negotiating valid credentials with the DNS server during the processing of the update request.

You can manually retry DNS registration of the network adapter and its settings by typing 'ipconfig /registerdns' at the command prompt. If problems still persist, contact your DNS server or network systems administrator.

The above issue exists on all windows Server 2008, Server 2012 & Windows 8 machines.

I have ensured that on the client machines the domain admins group exist in Adminsitrators group.

Can somebody please advise what could be wrong here.

Regards, Eager2Learn

  • Do you have a reverse lookup zone in DNS? – joeqwerty Sep 13 '16 at 21:25
  • Yes Reverse lookup zone is there. – Eager 2 Learn Sep 14 '16 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.