0

I have been setting up Fail2Ban and ufw. I have added my IP to ufw and fail2ban whitelists, but after simulating mutiple failed ssh login attempts it seems my IP has been banned.

I get the following error message in putty and FileZilla when using the 'banned' IP to attempt a connection: "Network error: Software caused connection abort".

I looked in the fail2ban jail, but there were no active bans. My IP is whitelisted in IP tables yet I cannot attempt a connection over Putty or FileZilla. I tried from another IP and it connects without issues.

Given that I cannot find my IP blocked in IP tables or in the fail2ban jail, what else could cause this? I have tried disabling ufw and rebooting the server multiple times.

Thanks

  • could you pls put here the output of sudo iptables -n -L -v? Beside would be good idea test with tcpdump if the connection from your ip address is established. – gsi-frank Sep 18 '16 at 15:52
0

The problem was with 'denyhosts' that came pre-installed so I was unaware of it. It did not create any entries in iptables, leading to the confusion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.