1

I use exim4 as a send only email on my servers, The FQDM I have on this servers is ws1.example.com (ws1,ws2,ws3...) and the email I use for receiving emails is a different smtp server with the email address being info@example.com , when I send email from my ws[num].example.com servers to any other service like gmail and hotmail everything works fine, also when I send email from any service(gmail,hostname..) to info@example.com everything works fine too, the problem is when I send emails from the ws[num].example.com servers to info@example.com I get "info@example.com: Unrouteable address" . Maybe the servers lookup for the address in the local hosts file since it is the same domain? How do I love it?

  • Are you NATing private addresses to public? Is the problem that it's trying to route from private --> public --> private and the NAT rules aren't set up to understand this? – NickRamirez Sep 18 '16 at 16:28
  • It looks like problem is indeed that @example.com is treated as a local domain that your ws1.example.com host itself is responsible for. You might want to check the domainlist local_domains settings in your config. – HBruijn Sep 18 '16 at 16:37
0

Try configuring your server to use the smarthost option. Use your mail server as the smarthost. If the name resolves to an Internet address, you may need to connect by IP address, add a host entry or configure hairpin NAT to your mail server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.