0

In ubuntu 14.04 i've installed postfix and i want it as "send-only email".

I have the following postfix configuration file (main.cf) (i change the real domain with mydomainname for privacy):

# See /usr/share/postfix/main.cf.dist for a commented, more complete version 
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated     defer_unauth_destination

myhostname = mydomainname.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = ubuntu, localhost.localdomain, , localhost

mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = localhost
inet_protocols = ipv4

Now if i try to send a test email (from command line) to a gmail account, the email is correctly received.

Instead, if i try to send the email to another email account i receive the following error:

mydomainname postfix/qmgr[1338]: 0F4462BD2A: removed
mydomainname postfix/pickup[1337]: 35F632BD2A: uid=1000 from= <alpha@mydomainname.net>
mydomainname postfix/cleanup[3275]: 35F632BD2A: message-id=<20160919105253.35F632BD2A@mydomainname.net>
mydomainname postfix/qmgr[1338]: 35F632BD2A: from=<alpha@mydomainname.net>, size=350, nrcpt=1 (queue active)
mydomainname postfix/smtp[3277]: 35F632BD2A: to=<xxxx@alpha-si.com>, relay=mx.alpha-si.com[62.149.128.166]:25, delay=0.54, delays=0.01/0/0.12/0.4, dsn=5.1.0, status=bounced (host mx.alpha-si.com[62.149.128.166] said: 550 5.1.0 lNst1t01g3nh0tZ01NstKv dominio non valido / invalid domain (in reply to MAIL FROM command))
mydomainname postfix/cleanup[3275]: B90BC2BD48: message-id=<20160919105253.B90BC2BD48@mydomainname.net>
mydomainname postfix/qmgr[1338]: B90BC2BD48: from=<>, size=2271, nrcpt=1 (queue active)
mydomainname postfix/bounce[3278]: 35F632BD2A: sender non-delivery notification: B90BC2BD48

what's the problem? how can i send email to all domain?

  • Do you have reverse DNS set up? Its interesting that gmail accepts it, they are usually picky about this. – mzhaase Sep 19 '16 at 12:06
  • yes, i have reverse dns set up – Tom Sep 19 '16 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.