0

Exchange 2016 using Outlook 2016 client

Created a new Public Folder titled

Mail-enabled the public folder:

Enable-MailPublicFolder -Identity "\PublicFolder"

Added Send As permissions.

Add-ADPermission PublicFolder -User domain\jsmith -Extendedrights "Send As"

Added permissions to receive mail.

Add-PublicFolderClientPermission -identity "\PublicFolder" -User Anonymous -AccessRights CreateItems

Set Hidden from address lists false:

Enable-MailPublicFolder -Identity "\PublicFolder" -HiddenFromAddressListsEnabled $False

The user jsmith is an owner of this public folder. He can add the public folder and the public folder can receive emails but nobody is able to "Send As" the public folder.

Under EAC I have verified that the public folder exists, permissions are in place, and the folder is mail-enabled.

I have tried disabling Mail Settings and re-enabling. I am also completely unable to select "PublicFolder" in my "From" field in OWA. It gives no option to enter a custom name and also doesn't have an option for the PublicFolder. I did add it to my Favorites.

The user receives the message "This message could not be sent. Try sending the message again later, or contact your network administrator. You do not have the permission to send the message on behalf of the specified user. Error is [0x80070005-0x0004dc-0x000524]."

The user has both Send As and Send on Behalf Of permissions.

The issue has lasted more than 24 hours so I am fairly certain that it is not a replication issue.

0

"The user has both Send As and Send on Behalf Of permissions. "

First, you need to set one or the other. Not both. Therefore remove one.

Does the public folder appear in the GAL? If so, that is how you populate the From field. You cannot just type the address in. If it doesn't appear in the GAL then you need to wait for it to do so. Outlook in cached mode will use the OAB, so you could force the OAB to update

get-offlineaddressbook | update-offlineaddressbook

Wait half an hour then force the client to download the OAB from the Send/Receive menu.

  • It started working when I enabled and then disabled "Automatically updated email addresses based on the email address policy applied to this recipient." Although I think that has nothing to do with the issue and it was merely a coincidence of replication that led to it working suddenly. Currently it is working with the user having both Send As and Send on Behalf Of. Why would it need to be one or the other? – anthonyblue Sep 20 '16 at 20:22
  • If you have both set, then you have no way of controlling which one is actually used. Therefore you need to decide which one you want and then set the permission. They are not the same. Your setting change probably forced an update within Exchange, which is why it started working. – Sembee Sep 21 '16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.