I replaced a Dell tower running PFSense 2.2 that kept needing to be rebooted with a Nokia (Nokia Checkpoint IP390 8 Gigabit Ethernet GbE 4GB CF 1GB RAM) rack mount appliance running the newest PFSense 2.3 that I got off eBay.

Things seemed to go smoothly except that the server isn't forwarding DNS info to the DHCP clients. The clients have full access to the internet and I can manually configure them to use Google's DNS servers. The PFSense server has DNS working on it, I can ping domains just fine from there, and the clients have it configured as the gateway and DNS server for them.

Unbound is installed, running and from what I can see is configured correctly with nothing checked under DNS Forwarder, but DNS Resolver is checked for all interfaces.

I have the local clients going for now by manually configuring each ones DNS, but would like to fix the server to work correctly so I don't have a headache each time I plug in a new computer.

For what it is worth, the interface is also REALLY slow, even from the local console it may take 10 seconds to respond. I just got into the office and on the console just hitting ENTER took it about 15 seconds to refresh the admin menu the first time, and about 5 seconds the next time.

Any help is appreciated.

2 Answers 2


If the DNS forwarder is enabled, the internal interface IP for pfSense will be handed out to DHCP clients as a DNS server. If the DNS forwarder is disabled, the DNS servers configured on pfSense will be handed out instead. https://doc.pfsense.org/index.php/DNS_Forwarder


DNS resolver and DNS forwarder are mutually exclusive services. By default, DNS resolver will be enabled and DNS forwarder will be disabled. We have to flip them to forward the DNS requests from LAN to WAN.

  1. Login to pfSense web console.
  2. Click on DNS Resolver under Services tab, uncheck Enable DNS resolver and save and apply.
  3. Click on DNS Forwarder under Services tab, CHECK Enable DNS forwarder and save and apply.
  • Thanks, not sure why the Forwarder would work when the Resolver doesn't, but this seemed to fix it in my case.
    – mwfearnley
    May 4 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.