1

I have a very tiny network in one room, with one Fedora laptop connected to a Dell PowerEdge server with CentOS. They communicate through an unmanaged wired Ethernet switch, which itself is connected to an AC1750 router that acts as a bridge to the pre-existing WiFi. The server has a static IP, everything else is dynamic.

I got SSH and Telnet to work between the client laptop and the server, then 45 minutes later, neither work again (connection timeout). The WiFi bridge is fine, otherwise I wouldn't be posting this with the laptop right now. ssh localhost also works just fine on the server. Oh, and pinging works too.

Any suggestions or theories why SSH would just die an hour after working?

4
  • Random thought: Check the network settings the laptop is getting, maybe it renewed its lease and has some weird netmask that excludes the server. Otherwise, timing out is classic firewall behavior. – DerfK Sep 21 '16 at 22:38
  • I should have mentioned that I disabled firewalld for purposes of testing/development, and iptables isn't installed. Short of hardware failure (and Dell OMSA hasn't reported NIC issues), or issues relating to the WiFi bridge (my next attack plan is Wireshark), I am out of ideas. Also, I tried a static IP on the laptop too, just to be sure. This changed nothing, but here's a quirk: When I disconnect/reconnect to the network, I have a working SSH, but for mere seconds, then back to status quo. – SomeDude Sep 21 '16 at 22:41
  • Just to be clear, it worked for 45 minutes then never worked again? Or it works for 45 minutes then times out, but you can reconnect? The second is usually caused by bad session management in the router (especially if it only happened when you were idle, usually solvable by enabling keepalive in ssh) but if the laptop and the server are plugged into the switch that shouldn't be it. – DerfK Sep 21 '16 at 22:44
  • All things considered, I am willing to bet a decent half-dollar that the laptop is at fault. The picture I'm gathering from my testing is this: for only seconds after connecting back to the switch with the laptop, I can connect to the server via SSH/Telnet. Then, I timeout on every other attempt. I don't get a working connection again until I reset my link to the switch. I don't feel the switch is at fault, because the internet connection goes through perfectly. – SomeDude Sep 21 '16 at 22:48
1

Found my solution: Switched NICs on the dual-NIC server. Now SSH/Telnet work without problems. It is possible that I configured my NICs in CentOS in a manner conflicting with their setup in hardware-level iDRAC. Changing from eno1 to eno2 (and thus from IP ...216 to ...217) solved all connection problems.

Lesson learned:

When having a problem with a dual-NIC server, it might be as simple as switching NICs to fix it.

2
  • mark it answered – Xalorous Sep 22 '16 at 0:42
  • Doesn't let me for two days – SomeDude Sep 22 '16 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.