2

I'm trying to copy several terabytes from one server's 4TB Storage Space to another server's 4TB Storage Space, but the copy is failing due to the Storage Space on the second server running out of room with over 600GB of additional invisible phantom data.

Configuration:

Server 1 (Source): Windows Server 2012 Essentials, 4TB (3.63 TB formatted) mirrored ReFS Storage Space, file integrity streams enabled. Storage Space contains 3.01TB worth of files, with 554GB free space.

Server 2 (Destination): Windows Server 2012 Essentials, 4TB (3.63 TB formatted) mirrored ReFS Storage Space, file integrity streams enabled.

File copying is done over the network from Server 1 using FastCopy with Verify enabled.

The file copy fails at about 3TB worth of files, with Windows Explorer on Server 2 reporting the destination 3.63TB Storage Space volume as being completely filled. Windows Explorer reported the folder with the transferred files as being just about 3TB. This leaves 652GB worth of something filling the volume completely unaccounted for.

There are no other files or folders on the volume containing this 652GB. The transferred data is the only folder in the root of the volume, apart from the Recycle Bin and (possibly the first time) System Volume Information (the only other obvious places to look for the phantom data).

There are no shadow copies on this volume according to vssadmin list shadows, and vssadmin list shadowstorage does not show any shadow storage on the volume.

I have tried running several disk usage utilities - WinDirStat, TreeSize, and SpaceSniffer - and only TreeSize could even see there is something else filling the volume besides the 3TB of transferred data. However, TreeSize reported this 652GB of something as "Unknown".

I even tried running several of these utilities under the Local System account, including Sysinternals' Du (disk usage), and it didn't change anything. The utilities still couldn't see there was something filling up the extra space (aside from the aforementioned TreeSize), let alone any details on what the phantom data might be.

I deleted the volume, the Storage Space and the Storage Pool on the destination server and then rebuilt them from scratch and started the file copy again. Halfway through the file copy process I checked, and there was already nearly 300GB worth of unaccounted for data on the destination server's Storage Pool volume.

Near the end, at the nearly 3TB mark, the file copy failed again, just like the first time, with the hundreds of gigabytes of something filling up the rest of the volume. Again.

Anybody have any idea what is going on here?

  • You probably already checked this, but it is not swap and/or space reserved for system restore? – mzhaase Sep 22 '16 at 11:21
  • No page file on the drive, and I don't see a way to make System Restore points in Server 2012; rstrui.exe is not even present in C:\Windows\System32. – QWERTY Sep 22 '16 at 12:31
  • By the way, I deleted ~700GB worth of the files copied to the Storage Space on Server 2, and TreeSize showed the "Unknown" data on the volume dropping from 652GB to 489GB. So whatever it is, it fluctuates in proportion to the copied data on the drive. – QWERTY Sep 22 '16 at 12:38
  • I'm not very familiar with ReFS, but could the two volumes be formatted with different block sizes? If one has a much larger block size, and you have millions of small files, you could be losing space there. – Mark Henderson Sep 22 '16 at 14:08
  • ReFS has a fixed 64KB cluster size. Also, a good deal of the files are of decent file size. – QWERTY Sep 22 '16 at 14:16
-1

Run command CHKDSK and check the output if 'total disk space' differs from space reported.

You can run the CHKDSK C: /F command to check and repair possibly lost space not associated to files, and check again the total disk space reported.

See this Microsoft article to check if any of the listed problems could be possible in your system:

Cluster Size Is Too Large
File Attributes or NTFS Permissions
Invalid File Names
NTFS Master File Table (MFT) Expansion
Alternate Data Streams
NTFS File System Corruption
Other NTFS Features That May Cause File Allocation Confusion
  • 1
    Does CHKDSK work against ReFS volumes? I thought the whole point of ReFS was to not need any post-corruption repairs.. – pauska Sep 22 '16 at 14:17
  • You're right. Try to run CHKDSK on a ReFS volume and you get "The type of the file system is ReFS. The ReFS file system does not need to be checked." – QWERTY Sep 22 '16 at 14:20
  • For ReFS filesystem you can still check some problems related to your configuration: are both disks the same cluster size ? Have you checked alternate data streams, or if exists some system/hidden folders – F.Igor Sep 22 '16 at 14:39
  • 1) ReFS has a fixed cluster size of 64KB. 2) I'm running Server 2012; Alternate Data Stream support for ReFS was added in Windows 8.1/Server 2012 R2. 3) Yes, I checked the system/hidden folders, which consisted of the Recycle Bin, and possibly also the System Volume Information during the first go-round. – QWERTY Sep 22 '16 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.