5

I'm trying to clone a LUN on a server and present it to the same server and am running into UUID oddities. I don't create partitions on the LUN, just create a PV and then LVM on top of that so I can grow it online as needed. The cloned LUN has the same UUID as the source LUN for the LVM and the PV, which is to be expected. I change the UUID of the PV using vgimportclone and then change the UUID of the LVM with tune2fs, no problems with those. What I'm running into is the UUID of the physical disk, which should have the same UUID of PV, doesn't update until I reboot the server. To deepen the mystery, if I run blkid on the LUNs underlying disks, it shows me the old UUID, but if I run udevadm on those same disks, there is no UUID.

So I have 2 questions.

1) Anyone know whey blkid and udevadm would show different information?

2) Is there a way to refresh the UUID of the physical disk without a reboot?

Server: RHEL 6.5 device-mapper-multipath-0.4.9-87.el6.x86_64 lvm2-2.02.143-7.el6.x86_64

Thanks, DarkSide

0

You can reread partition informations with command

partprobe /dev/sda

UUID is partition-specific, so it also refreshed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.