1

I have a webserver, and I am migrating it over to RHEL7 (httpd 2.2 -> 2.4). In our old server (2.2), we could do a httpd fullstatus, and it would show a lot of good information about apache on the server.

On the apache 2.4 server, I am having issues getting the fullstatus command to work. Here is a list of steps that I took (compiled from various guides around the internet) -

1.) - Checked if status_module is enabled. httpd -M | grep status returns status_module (shared).

2.) - Added the module into the httpd.conf -

<IfModule mod_status.c>
    <Location "/server-status">
        SetHandler server-status
        Require host <my hostname>
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1

    </Location>
</IfModule>

3.) - Created a conf file inside of conf.modules.d/ (with the same words as above) -

<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from 127.0.0.1
</Location>

I reloaded / restarted apache after doing all of those things, but I still has no luck in getting httpd fullstatus to work.

NOTE - I did both of these steps individually as well with no luck, which is why I put them together with the hope that it would work.

Do you guys have any ideas on what I should do for a next step?

Thanks.

EDIt - This is the current output whne I try to run httpd fullstatus -

[username@hostname]# httpd fullstatus
    Usage: httpd [-D name] [-d directory] [-f file]
             [-C "directive"] [-c "directive"]
             [-k start|restart|graceful|graceful-stop|stop]
             [-v] [-V] [-h] [-l] [-L] [-t] [-T] [-S] [-X]

EDIT2 - When running apachectl fullstatus, I get a permission denied error -

                               Forbidden

 You don't have permission to access /server-status on this server.
  • What do you mean by fullstatus? What did actually happen? Oh and don't use "require host <myhostname>" as it causes Apache to have to request DNS resolves, the "allow from 127.0.0.1" is entirely sufficient.ALso you do not need to add this twice, once in the global context is enough. – Unbeliever Sep 24 '16 at 16:06
  • Additionally, for apache v2.4 dont use the apache v2.2 auth directives, convert to the apache v2,4 once and do not load mod_access_compat. See the Upgrading page for details. – Unbeliever Sep 24 '16 at 16:08
  • I added the output to the original question. Would not loading the mod_access_compat module with the original directives in there cause this output? – user374987 Sep 25 '16 at 1:28
1

fullstatus is an option of the apachectl command, not of httpd. From the usage output, it sound like that is the problem here. Try

apachectl fullstatus
  • ok, that fullstatus :) That is an argument to apachectl only (not to httpd). It requires lynx to be installed and in your path. You may also need to modify the STATUSURL variable in apachectl depending on the port your web server is running on. You can also try it manually with curl. e.g. curl -O /dev/tty localhost:9090/server-status?auto Alo please say exactly what does happen when you run 'apachectl fullstatus' – Unbeliever Sep 25 '16 at 12:26
  • I updated the orignal question with the output. I have already installed links (instead of lynx). Would this permission denied thing go away with the updated syntax? – user374987 Sep 25 '16 at 23:45
  • I got it all working. Thanks to both of you for the help. I had to change 127.0.0.1 to "localhost" after switching to the new directives outlined in the apache page. – user374987 Sep 26 '16 at 23:06
  • Doesn't that depend on wether you use a redhat- or a debian-based linux distro? – sjas Mar 3 '17 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.