7

I have a small Hyper-V environment, but since today I cannot ping from the VM to outside, and not from the local network to the VM.

My situation/network in short:

  • Router: 192.168.1.254
  • My Hyper-V Host/Computer: 192.168.1.10
  • My Virtual Machine: 192.168.168.1.110
  • They ALL have gw=192.168.1.254, subnetmask: 255.255.255.0
  • None of the computers have the windows firewall enabled
  • The VM is connected via a external Virtual Switch, that is bound to my only NIC in my PC. (Allow management operating system to share this NIC = on)
  • I always ping using the IP

From my computer (192.168.1.10) I can ping all components in the network, like GW and others. But I cannot ping the VM.

From the VM, I can ping the default gateway, and other VM's, but none of the other NIC's in the network, for example 192.168.1.10

This used to work, I didn't change anything, and it stoped working. I think this has to do with the virtual switch of Hyper-V, anybody have a tip on where to look?

9

Long story short: remove the virtual switch from Hyper-V, recreate it, and everything worked again...

  • Indeed, solved the issue. – W.M. May 1 '18 at 15:38
  • Solved for me also. – vukis Sep 14 '18 at 7:16
  • Still a working solution more than years later on the latest Win 10 Insider build. – paradroid Dec 5 '18 at 1:13
  • Had the same issue. Everything worked, I didn't change anything. Then it broke. I could ping the VM from another computer, but not from the local machine (the same thing with HTTP access). Very funny, yeah? Recreating the virtual switch solved the problem! – Mike Siomkin Jul 24 '19 at 17:51
  • Yep good. killed it and made it again. Worked. – Justin Dec 15 '19 at 23:18
3

reason is!!Firewall!!

Disable Firewall, or to be specific in the firewall settings, allow bellow app to communicate through fire wall and issue will be resolved:

File and Printer Sharing (ICMS)

  • in my case the rule was "File and Printer Sharing (SMB-In)" – Okneloper Sep 17 '20 at 8:31
0

Happened to me after host system update. VM client is Windows 7 and must have seen the updated virtual switch as a new network. Recreating virtual switch as above didn't work for me. Solution for me was to either

(1) within VM, set network location from Private to Home

-- or --

(2) within VM, allow network discovery in Private

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.