0

I'm trying to create a scheduled task on Server 2012 R2 to run as a domain service account. I select "Run whether the user is logged on or not", and select the domain service account, click on OK, enter the credentials, and then I get this error message:

An error has occurred for task LPAEmail. Error message: The following error was reported: A specified logon session does not exist. It may have already been terminated.

Things I've already tried:

  • Checked that Network access: Do not allow storage of passwords and credentials for network authentication policy is disabled.
  • Logging on to the server as the user.
  • A different domain account.
  • Tried using the local administrator account.
  • Adding the domain account to the local Administrators group.
  • Changing "Configure for" to Vista, Windows 7, and Server 2012 R2. None of them made a difference.
  • Setting to a local account, and then entering credentials for a domain account when prompted.
  • Verified "Password never expires" is checked for the service account.
  • Tried creating a completely new task.

Does anyone have any suggestions on what else to try?

Note: I discovered if I check "Do not store password. The task will only have access to local computer resources.", it works. But this is not an acceptable solution, because the task needs to access remote resources.

  • Would anyone care to explain why this was down voted? – Drew Chapin Sep 27 '16 at 16:23
  • Did you verify the storage of password setting with GPEdit or RSOP? GPEdit will show the local setting. RSOP will be the effective setting. Downvote was not me. – Clayton Sep 27 '16 at 17:49
  • @Craig620, through RSOP. – Drew Chapin Sep 27 '16 at 17:55
  • Create an new empty task, and try tu put again that user in. I wonder if the task's config are corrupted. (Strange error happen when the file (where the task is saved) got invalid/corrupted entry) – yagmoth555 Sep 27 '16 at 18:01
  • @yagmoth555, I already tried that. Same error. Thanks though. – Drew Chapin Sep 27 '16 at 18:25
0

Turns out the issue was the Credential Manager was disabled via the following registry settings:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"DisableCredMan"=dword:00000000
"disabledomaincreds"=dword:00000000

Both values must be set to 0 in order for the Credential manager to work with domain accounts.

  • Note: There was no mention of "Credential" or "CredMan" on the output of gpresult /h report.html. – Drew Chapin Sep 28 '16 at 14:33
  • Don't you mean DisableCredMan was set to 1 and you set it to 0 to enable it? – Bill_Stewart Oct 1 '16 at 15:04
  • @Bill_Stewart, I don't see any contradiction between what I wrote and what you said – Drew Chapin Oct 2 '16 at 0:25
  • Sorry, your answer says the credential manager is disabled by the zeros. Actually both must be set to 0 (as you say after, but it seems contradictory). – Bill_Stewart Oct 2 '16 at 2:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.