1

We have a Windows server running Apache 2.2. It used to have SlikSVN 1.8.x installed and we load the SVN module from httpd.conf:

LoadModule dav_svn_module modules/mod_dav_svn.so

We recently upgraded SlikSVN to 1.9.4, I did not have the idea to reboot the server after the upgrade, as everything was apparently working fine.

Now the server was rebooted today, and now Apache service won't start. Event log reports:

The Apache service named  reported the following error:
>>> httpd.exe: Syntax error on line 130 of D:/web_server/apache/conf/httpd.conf: Cannot load D:/web_server/apache/modules/mod_dav_svn.so into server: The Apache service named n\x92est pas une application Win32 valide.     .

Any idea what's happening?

  • Is that supposed to work and could mod_dav_svn.so file be simply corrupted?
  • Is Apache 2.2's mod_dav_svn.so be incompatible with SVN 1.9 and require SVN 1.8? Then what should I do?
    • Upgrade Apache to a more recent version (how to know which one will be compatible with the SVN version I use)?
    • Can I get a new version of mod_dav_svn.so supporting SVN 1.9 and compatible with Apache 2.2? Because the server runs old Redmine services and too and I'm afraid Apache upgrade won't be obvious...
  • What's your OS ? – Iain Sep 29 '16 at 10:56
  • @Hangin: Windows server – jpo38 Sep 29 '16 at 11:27
  • What version, is it 64bit or 32bit ? – Iain Sep 29 '16 at 11:42
  • @Hanginoninquietdesperation: Windows server 2008 R2 enterprise 64bits. Apache 2.2 I'm using is 32bits, SVN 1.8 was 32bits too. But SVN installed now is 64bits....I guess that could be the issue, is mod_dav_svn.so looking for svn.exe in %PATH%? If yes, it's going to find a 64bits version here... – jpo38 Sep 29 '16 at 12:09
2

... The Apache service named n'est pas une application Win32 valide
... The Apache service named is not a valid Win32 application.

It looks like you have installed a 64bit library into a 32bit apache

You should replace D:/web_server/apache/modules/mod_dav_svn.so with a suitable library.

  • The problem must be somewhere else. I did not modify the apache folder, I only upgraded SVN, mod_dav_svn.so did not change, it's the one packaged with Apache 2.2 I'm using. I even tried to reinstall SVN 1.9 32bits instead of 64bits and I'm still getting the same error... – jpo38 Sep 29 '16 at 12:39
  • I'm not a windows admin or a French speaker but the error message seems quite clear that mod_dav_svn.so can't be loaded. – Iain Sep 29 '16 at 12:41
  • Sure, that's what it says, but I can't figure out why. It's most likely note mod_dav_svn.so that has to be changed, it's timestamped from 2011 and has been working for 5 years now. It must need something it does not find when being loaded.... – jpo38 Sep 29 '16 at 12:51
0

The 1.9 version of SVN I installed (added to %PATH%) was 64bits, while Apache was 32bits. That was most likely the problem.

After trying many things, I ended up installing Apache 2.4 with SVN 1.9 32bits and it now works.

I did not get a chance to test Apache 2.2 with SVN 1.9 32bits (as I already had upgraded Apache when I realized this 32/64 mismatch), but it would probably have worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.