1

I've configured a dns and slave service using bind which works as expected.

More recently I've set up Webmin so that I can use the GUI to update zone files.

I am able to update the zone files, and increment the serial number automatically within Webmin, but this info doesn't automatically transfer to my slave dns server (***Note- my slave dns and master dns are definitely configured correctly as they have been working as expected for the last few month via command line only configuration).

At the moment, after updating the zone info in Webmin, in order for the updated information to transfer to to the slave dns, I am having to run

service named reload

in the command line. Is there a feature in Webmin that could replicate this command?

Thanks

  • Is the problem that you need to manually run service named reload on the slaves? – HBruijn Sep 29 '16 at 16:23
  • No, I only have to run it on the master. The issue is I want to administer the service only via Webmin and not have to then issue a command in command line. – treetop Sep 29 '16 at 16:38
  • Then disregard my answer ... Isn't there an apply changes button in Webmin's bind console? – HBruijn Sep 29 '16 at 16:50
  • @HBruijn if there is it's well hidden as I can't see it! :) – treetop Sep 29 '16 at 16:52
1

From the manual: http://doxfer.webmin.com/Webmin/BIND_DNS_Server

To activate the new record so that it can be looked up by DNS clients and other servers, you will need to click the Apply Changes button on the module's main page. If you are planning to add or edit several records, it is usually better to wait until all the changes are complete before hitting the apply button. If it is available, you can instead use the Apply Changes button at the bottom of the master zone page shown below. This uses the ndc command to tell BIND to re-read only the file for this zone, which can be much faster on a system that hosts are large number of domains.

enter image description here

  • Thanks, my issue was originally that the "apply" option wasn't available. However I've since change some of the configuration settings and it's now appeared, although in my version of webmin it is called "Apply Configuration". Cheers for your help. – treetop Sep 30 '16 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.