0
$ ls -l .htaccess
lrwxrwxrwx 1 suseika suseika 74 Oct  1 03:35 .htaccess -> /home/suseika/some/path/to/the/actual/.htaccess

Apache just ignores such .htaccess. If I create a file instead of a symbolic link, it works properly. Can I configure Apache 2.4 to use that symlinked .htaccess?

1
  • Does the user that apache is running as have access to that file, including the ability to traverse that path?
    – 84104
    Sep 30, 2016 at 23:42

2 Answers 2

0

You need to enable the following of symlinks with the Options directive

1
  • It is already enabled
    – jojman
    Sep 30, 2016 at 23:48
0

The problem I had doesn't have anything to do with apache config. I run apache in a Docker container, and the symbolic link pointed to a file that is not available in that container.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.