11

I just recently installed ESXI on a server for some basic tasks, but now I'm having a problem with my windows VM.

The thing is, the bottom and the right-hand side of the screen go beyond what the VSphere Client is showing me (This happens with an external console as well as the tabbed one)

Here is what I mean:

  • "New Window" console:

    "New Window" console

  • "Tabbed" console

    "Tabbed" console

I haven't been able to find ANYTHING pertaining to this on here or on google. What I tried so far, however:

  • Restart the server VM
  • Restart ESXI
  • Restart my Computer
  • Go to View -> fiddle with the auto-fit settings (no change at all)
  • Change the VM's resolution (Migitated the problem somewhat, as I can see more window content, but there is still a lot missing at 1024x786, which is the smallest it willl go)
  • Change my resolution
  • Unplug my extra screens (I have 3 including my laptop)

The used ESXI Server is Version 6.0.0, I am on Windows 10.

Any ideas?

  • 1
    Are the VMware tools installed inside of the VM? – Gerald Schneider Oct 4 '16 at 7:24
  • Ah, no, they're not. It's a little hard to, windows is missing about a third of it's UI on the lowest resolution. I'll try to get it on there. – Eskir Oct 4 '16 at 7:35
  • 3
    If VMware Tools doesn't fix it (it didn't for me) test this: Right click the vSphere Client shortcut, select 'properties'. On the 'compatibility' tab check the 'Disable display scaling on high DPI settings'. Ok that, then relaunch vSphere client. – jscott Oct 4 '16 at 14:57
14

This is easy to fix, go properties of the vSphere Client shortcut icon (used to launch vSphere) >> compatibility >> tick "disable display scaling on high DPI settings"

  • 1
    This fixed the problem for me on Windows 10. – Cole Apr 3 '17 at 19:04
  • Took me ages to work out what this answer meant. By "vSphere Client Shortcut" it actually means the icon you use to start vSphere client. You need to find it in explorer as the task bar or start menu no longer give you an option of properties in windows 10. Once I did that the problem was sorted although the fonts go a little crazy – MikeKulls Dec 11 '17 at 11:45
1

The problem has to do with Windows 10 scaling and the vSphere remote console client. It needs fixed, but will not be fixed since everything is moving to the web. So a better fix is in windows 10 (and 8.1 I believe) Right click your desktop and go to display settings. There is a “zoom slider” just under the pictures of the monitors. Set it to 100%.


A better fix is in windows 10 (and 8.1 I believe) Right click your desktop and go to display settings. There is a “zoom slider” just under the pictures of the monitors. Set it to 100%.

The problem has to do with Windows 10 scaling and the vSphere remote console client. It needs fixed, but will not be fixed since everything is moving to the web.

  • 1
    I deleted your other answer and added that info to this one. ServerFault is a Q&A platform and not a forum, please use edit function to revise answers rather than posting such new insights as new answers. – HBruijn Apr 26 '17 at 9:45
0

VMware ESXi defaults to a resolution of 640 x 480 px for new Virtual machines without guest tools installed or any settings changed. You have basically three choices:

  • Live with it, because you manage the VM in other ways (SSH, specific application that runs on the server, automatic management/deployment, etc.)
  • Install guest tools like Gerald Schneider suggested (they not only support nearly all resolutions and auto-change of resolutions, but also remove the annoying Mouse/Keyboard-lock in the VNC client), this would also be my personal suggestion
  • Change the resolution manually without guest tools installed, as described by VMware here: Adding video resolution modes to Windows guest operating systems (1003)

If you have trouble navigating the reduced UI before installing the tools, I would suggest to use Keyboard shortcuts: hitting Alt + Space on the currently active window gives you a menu where you can select Move (DownArrow 2 times) and Resize (DownArrow 3 times), hit Return and then move/resize the window with the arrow keys. I only tested it in Windows 7, but it should also work in 10.

  • I tried everything. I reinstalled VSphere (even using the clean-tool vmware provides), installed guest tools (It did remove the mouse lock, but I still didn't see more of the console, no matter the settings), I basically did everything short of reinstalling windows (which I can't afford to do right now) – Eskir Oct 12 '16 at 11:05
  • What I ended up doing was use RDP, this makes testing pre-login things difficult/impossible though. I can live with this, but it's still hardly ideal. I might get back to this question once I have tried reinstalling my system. – Eskir Oct 12 '16 at 11:06
  • @Eskir It is strange that the Tools did not change it. Do you have sufficient memory allocated on the VM settings window under graphics adapter? You can also connect to the machine directly with VNC (it is unsupported and a slight hack, but for testing it's definitely useful). See for example virtuallyghetto.com/2012/01/… – user121391 Oct 12 '16 at 11:36
  • I changed the video settings to maximum, from 4mb to 128mb, didn't change anything. I'll see about VNC. – Eskir Oct 13 '16 at 8:02

protected by Community Apr 25 '18 at 6:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.