4

At the school I am the technician off, we have Windows Server 2012 that are giving students access to their user shares through a folder redirection GPO. Anytime a user signs in their home folder's display name gets changed to "My Documents". I need them to still display as lastname.firsname so the teacher can tell whose files they are accessing.

I already tried the solution stated in the this article Shared Home folders on file server listed as “My Documents”and it did not work. I searched for the desktop.ini files in the folders of the users that have been afflicted by this issue only to find none.

I also tried having the folder redirection point to a documents and favorites folder within the users' home folders.

Any help would be great.

4

The folders aren't being renamed. They have a Desktop.ini file present and Windows Explorer is using the instructions in that file to alter the name being presented on-screen. The files are hidden by default, and unless you've asked Windows Explorer to display hidden files and unticked the "Hide protected operating system files" you're not going to see them.

If you do find and delete them they're just going to come back. If you're like me, you can use a File Screen to prevent the files from being created in the first place. That's what I've done most everywhere because I find the desktop.ini files provide little utility.

  • How do you add file screens in Server 2012 – Gocpodin Oct 4 '16 at 15:20
  • It's very similar to Windows Server 2008 R2 (which is the version of documentation I linked-to in my answer), but you can find specific documentation for Windows Server 2012 R2 here: technet.microsoft.com/en-us/library/hh831701(v=ws.11).aspx A step-by-step is beyond the scope of this question or these comments. Play with it for a little bit on a scratch folder hierarchy and you'll figure it out. You'll also want to delete the existing 'desktop.ini' files. Once you get Windows Explorer to show them you to you deleting them will be a cinch. – Evan Anderson Oct 4 '16 at 15:55
0

What I do is add a column to the Windows Explorer that shows the filename. Rightclick on any column header and click on the last option : "More...". Scroll down to find and place a check mark in front of "Filename" and click OK to close the dialog box. You now have an extra column showing yhe exact filename of the folder (firstname.lastname). If you want, you can drag the column headers around to change the order of the columns. You can also change the preferences of Windows Explorer to always show this extra column for this type of folders. Good luck!

0

Sometimes the simple way will work! This took me a long time to figure it out, trying to find solution after solution from different sites. I tried the simple way! Re-create the Desktop ini file. Take a Text document copy from a previous user. You will have to search in Explorer from a current user that has an active ini file. Copy the script and change the user profile. Then Save the Text document to Desktop.ini and remove the original Text document after you have saved it. This works.

[DeleteOnCopy]
Owner=**ted**  Rename Ted to New User name
Personalized=5
PersonalizedName=My Documents

Realize you may have to create this twice for it to take.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.