6

This question already has an answer here:

When connecting to a Linux SSH server using PuTTY, the PuTTY log shows 2 authentication attempts. The first attempt uses "root" as the username and no password. "none" is displayed in the first packet, meaning no password was used. The connection fails because the Linux SSH server is configured to only authenticate connections that have a password or public key. The second attempt uses "root" as the username and "SECRET" as the password. Access is granted because "root" and "SECRET" are a valid username/password for the Linux SSH server.

enter image description here

After clicking on the Open button in PuTTY, immediately the prompt to enter username "root" appears. After entering username "root", it takes about 8 seconds for the password prompt to appear. I am certain the cause of this 8 second delay is because the client and server are busy with the first authentication attempt that has "none" and no password. After entering password SECRET and pressing enter, access is granted immediately.

enter image description here

I am not certain why PuTTY first attempts to connect with username "root" and no password. Is there some way to configure PuTTY to not make the first attempt with username "root" and no password.

marked as duplicate by Iain, Community Oct 7 '16 at 4:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Export HKEY_CURRENT_USER\Software\SimonTatham and erase that key after, and try again please to connect. – yagmoth555 Oct 6 '16 at 2:17
  • Thank you for the recommendation to delete the HKEY_CURRENT_USER\Software\SimonTatham. I is definitely helpful to know exactly were in the registry PuTTY resides. I appreciate the insight. – JeremyCanfield Oct 6 '16 at 3:06
7

I'd also look at your DNS... maybe. Can the server you're connecting to resolve DNS properly? Could you add a temporary host entry with your source IP in the server to test?

See: SSH takes about 30 seconds to connect on my computer

  • Thank you very much ewwhite, this was indeed a DNS issue. I did not mention this - the IP addressing scheme of the LAN was redesigned prior to the latency with PuTTY, which is what introduced the DNS issue. Thank you very much for your answer. – JeremyCanfield Oct 6 '16 at 3:05
  • 1
    @JeremyCanfield Thanks for the good and well-formed question. – ewwhite Oct 6 '16 at 3:06
  • Just a quick question: Why is this a DNS-issue? Wasn't the connection already established when he entered his username or does putty only start the connection after you enter the username? – Broco Oct 6 '16 at 8:19
  • @Broco Because the SSH-server tries to reverse lookup the hostname for the IP address which is connecting. – Tobias Mädel Oct 6 '16 at 8:29
  • 1
    I was able to be certain that the 8 second delay was indeed a DNS issue. Recently, the IP address scheme in the LAN was revised. However, the Linux SSH servers were still pointing to the prior IP address of the DNS servers. Once the SSH servers were updated to have the new IP address of the DNS server, after entering username "root", the password prompt appeared immediately. I really appreciate all of the thoughts shared here. This was a good learning experience. – JeremyCanfield Oct 7 '16 at 4:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.