0

Here is what I did:

  1. From server manager installed BITS IIS Server Extension
  2. From IIS manager created virtual directory under default website (using DefaultAppPool with ApplicationPoolIdentity)
  3. From IIS manager, went to handler mappings, then edit feature permissions and disabled execute and script
  4. From IIS manager, changed the Authentication - I disabled anonymous authentication and enabled basic authentication
  5. I gave full control to all users I could think of on the virtual directory (everyone, DefaultAppPool, Network Service, ect...)

I get the following error when attempting to do an upload:

Error Code: -2145844748
Error Description: HTTP status 500: An unexpected condition prevented the server from fulfilling the request.
Error Context: RemoteFileError
Error Context Description: The error occurred while the remote file was being processed.

I have attempted to do an upload from a console app I created using the bits api on a cpu on the network and from the actual server using PowerShell. I am getting the same error both ways.

  • Have you tried uploading with small files (1kb)? Do you get the same error message? You might have to configure IIS to accept larger files and/or increase certain time-out values. – hot2use Oct 7 '16 at 12:58
  • @hot2use Yes the file I am testing is small (6kb). I haven't changed the time out value but the error happens well under the default time out value. Also I have been able to successfully download the same file using bits. – Dominik Holland Oct 7 '16 at 14:06
0

The issue was that the App Pool on IIS was 32 bit enabled. Once I disabled 32 bit the issue went away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.