I'm a new volunteer at a university radio station after the old network tech walked out.

I cannot connect to the radios CentOS server on which hosts our Icecast broadcast program which means we are not broadcasting anything across all channels. When I search in Chrome I get a basic error message of: didn't send any data


I've tried the basics and deleted the cache but I can't seem to figure out why I don't have access. Additionally I only have a very basic knowledge of CentOS and networking. Any help would be appreciated.

  • 1
    Please make sure Icecast is running. ps aux|grep icecast and netstat -plant|grep icecast should give you an idea if anything is running and on which port. Feel free to stop by the #icecast channel on Freenode - icecast.org/contact/#contact-info - for more interactive help. – TBR Oct 7 '16 at 14:05
  • @TBR Appreciate the reply, but can't really understand what I'm looking for when I input the commands. Any idea what specifically I need? – Alex Hamilton Oct 7 '16 at 15:06

I have googled your issue and someone has come up with the following solution that you could try. I will need to assume you are using a Windows operating system but please correct this if not so.

First you need to start command prompt with admin rights.

Once you have command prompt up and running, try these commands:

Run below commands one by one.

ipconfig /release
ipconfig /all
ipconfig /flushdns
ipconfig /renew

netsh int ip set dns
netsh winsock reset

Then restart your PC.

What this will do is release your IP, renew your IP and flush your DNS settings and reset your winsock.

I found this solution and full guide on this website here

  • It clearly says CentOS not Windows -- your answer is so far off, it's not even wrong. – TBR Oct 7 '16 at 14:07
  • From what I understand, the IceCast service is running on CentOS but the client browser he is using could be Windows as he stated he is using Chrome. Hence why I said I am assuming and needs correcting if not so to which I can edit my response. – SleepyMan Oct 7 '16 at 14:09
  • Yes sorry should have stated. IceCast is running on CentOS but I'm using a windows client to access it, – Alex Hamilton Oct 7 '16 at 14:50
  • 1
    Tried all these steps and no change sadly. I should point out that its not just this client that cannot reach the server, all other networked PCs within the radio station cannot reach it either. Additionally, no one attempting to connect to the streaming application can hear what we are broadcasting – Alex Hamilton Oct 7 '16 at 14:57
  • Are you able to run the commands that TBR suggested to see if the service is actually running and listening on the interface? This would be run on the CentOS server itself. – SleepyMan Oct 7 '16 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.