I've tried adding the domain controller to the host file, and I've also tried basically every trick I know of to make this work, but I get nothing.

Why do I get this error message? And what is the underlying issue here?

More details

I've noticed than nslookup sometimes does fail when I enter the domain controllers name, typically I try...

nslookup [SERVER]
nslookup [SERVER].
nslookup [SERVER].[DOMAIN]
nslookup [SERVER].[DOMAIN].

...and typically only nslookup [SERVER].[DOMAIN]. returns a response, but sometimes not even that. I've tried configuring the DHCP server diffrently, eventually only supply a single DNS server to the client, which is the DC itself. That usually fixes the nslookup issue but it doesn't explain why I can't join the domain.

If I disable NetBIOS over TCP/IP I get security problems related to the domain controller not being found by it's WINS name, or something like that. Apparently this also relates to the way our domain controller is set up.

Our domain name in Windows Server is just a single "name", a colleague of mine says that it could be part of the problem. According to some docs he read it should be something like [DOMAIN].local, but it isn't, care to comment?

[DOMAIN] and [SERVER] are placeholders for domain name and domain controller name.

The domain name [DOMAIN] might be a NetBIOS domain name. If this is the case, verify that the domain name is properly registered with WINS.

If you are certain that the name is not a NetBIOS domain name, then the following information can help you troubleshoot your DNS configuration.

DNS was successfully queried for the service location (SRV) resource record used to locate a domain controller for domain [DOMAIN]:

The query was for the SRV record for _ldap._tcp.dc._msdcs.[DOMAIN]

The following domain controllers were identified by the query:


Common causes of this error include:

  • Host (A) records that map the name of the domain controller to its IP addresses are missing or contain incorrect addresses.

  • Domain controllers registered in DNS are not connected to the network or are not running.

For information about correcting this problem, click Help.

  • Can you describe a bit more about all the 'tricks' you tried? – Zoredache Nov 3 '09 at 8:33
  • If you disable NetBios over TCP\IP then you shouldn't be able to do anything with the WINS names, you've just disabled the part of the stack that handles that. If you try to join using the fully qualified domain names does that work? – Helvick Nov 3 '09 at 11:05

Editing your Hosts file is a Bad Idea.

Your Domain Controller(s) are not registering with a DNS server correctly.

  1. Check the Domain Controllers IP settings, and ensure it's pointing at INTERNAL DNS servers (I guess in your case it'll be itself)

  2. Check the IP settings of the machine you are trying to join. If it's static, ensure it's pointing at INTERNAL DNS servers that the Domain Controller is pointed at

  3. Ensure that your DNS server is enabled and configured correctly

If all this fails, something more sinister is wrong. A dirty fix would be to manually add the A record to your DNS server for the relevant zone. It would be something like:


Furthermore - have you used netdiag or dcdiag?

  • I'm not familiar with netdiag or dcdiag, what can they help me with? – John Leidegren Nov 3 '09 at 10:52
  • 4
    +1 for STEP AWAY FROM THE HOSTS FILE – Maximus Minimus Nov 3 '09 at 11:31
  • 1
    They're both built-in tools on your DC. I suggest you learn to use them – Izzy Nov 3 '09 at 14:25
  • Test results for domain controllers: DC: Parallel.Mira Domain: mira TEST: Basic (Basc) Error: No LDAP connectivity No host records (A or AAAA) were found for this DC TEST: Dynamic update (Dyn) Warning: Failed to delete the test record _dcdiag_test_record in zone mira TEST: Records registration (RReg) Error: Record registrations cannot be found for all the network adapters – John Leidegren Nov 6 '09 at 13:29
  • 1
    Fix all of your netdiag and dcdiag errors that come up, then see if you still have problems. – sclarson Nov 6 '09 at 15:37

Are you sure that the DNS server on your machine that can't join is using the DNS server for AD and not another DNS server?

  • 1
    +1 for this: AD puts all sorts of entries into DNS for its own reasons. Machines in the domain need to use the same microsoft DNS server that the domain controller uses. Often this is the DC itself. – pjc50 Nov 3 '09 at 13:30
  • the DNS looks about right, still i get the same stupid error – John Leidegren Nov 6 '09 at 11:28

You should enable Location of the DCs hosting a domain with single label DNS name in Computer Configuration/Administrative Templates/System/Net Logon/DC Locator DNS Records on client computer, otherwise it will think that your single-label domain is netbios name.


We (unfortunately) have a single-label domain as well and operate without problems, however you must use Win2003 DC's. Win2K DC's need a patch to enable updates to a single-label domain.

You can operate a domain without WINS/NetBIOS. However, things like Nnet use x: \\server\share won't work; you need to use FQDN. That's separate from AD operation, however.

As usual, check your DNS zone. All underscored records there? All servers pointing to the same place as per MarkM's answer?


Is your DNS server pointing to itself for queries?

And you are giving your servers static IP addresses, right?

  • Yes, the server is configured to use the static IP address, it's gateway is and it's DNS server is – John Leidegren Nov 6 '09 at 19:42
  • I'd be more than happy to provide you with any information you might need to solve this problem. – John Leidegren Nov 6 '09 at 19:43

Few hours ago, I got same problem: can not join XP machine to the domain. DC is 2003 R2 SE, domain level - 2000. DNS and WINS, services are running, no error events exists. But when I trying to join computer to the domain, I got an error, that domain controller is nos accessible. Some words about WINS and DNS requests.

That's right: in DNS all records where correctly registered, nslookup with domain name resolves well with DC IP address, but in WINS server I didn't find one row, where record type must be domain controller and my domain name (of cause, IP address of DC must be there too).

What to do:

  1. right click on "Active registrations" in WINS administration console and "display records". Try to find domain controller. If not, do p.2
  2. Right click on "Active registrations" in WINS administration console and "New static mappings", in computer name field type domain name, choose type - domain name, IP address must be Your domain controller IP address. Click Add and OK to close new static mappings window.

That's all. Check, that your AD contains computer object, that You want to register, check group name, who owns permissions to register computer to the domain and Your account exactly have those permissions. Register to the domain Your new workstation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.