1

I need help configuring a switch (Datacom DM4000).

It has 2 ports, one for management and one for console (obviously more 24 ports for normal use).

With a RJ-45 to serial cable I was able to configure the IP from the management port and with a normal RJ-45 cable I could ping, access it with telnet and so on.

The problem was that not all my computers could access the switch.

I have 4 computers:

1 - Desktop Dell Vostro with Ubuntu 15.04

2 - old PC with Ubuntu Server 16.04 and 2 network interface

3 - Notebook Dell Vostro with some ubuntu

4 - Notebook Lenovo Yoga 900 with Windows 10 and a USB ethernet

The computers 1 and 3 can connect with no problem, the computers 2 and 4 can't!

I tried with 3 different cables, when I connect 1 or 3 the LED "Link/act" become on and when I use the command "ethtool ethX" say it is on. But when I connect to 4 or both network interfaces on 2 the LED stays off and the ethtool says it has no link. I even tried to use wireshark to capture any packet but nothing arrived.

My computer 1 has a little bug (at least I think so) that when I connect the cable it get no IP, even though is configured with static IP (but the link/LED is on), so I have to reset the interface (the link/LED goes off and on) and then get the IP and I can connect. All other computers are setup with static IP too.

Any ideia why this is happening?

The only thing in common that I can see is that both computers that work are from Dell, so maybe they have any different configuration but besides that nothing in common.

Any test that I can execute to try to see what the problem is?

The computer that I need the most to connect is 2 because it has two interfaces and I pretend to run several tests with it.

Thanks!

Edit

Providing more information:

Computer 1 ethtool connected to mgmt-eth:

sudo ethtool eth0
Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
                                         1000baseT/Full 
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes

Computer 2 ethtool connected to mgmt-eth: http://imgur.com/a/bDj8k

Computer 2 ethtool connected to console: http://imgur.com/a/QfC8h

DM4000 configuration: (running on computer 1)

DM4000(config-if-mgmt-eth)#show ip interface 
MGMT-ETH     172.20.0.3/20     

DM4000(config-if-mgmt-eth)#show interfaces status mgmt-eth
Information of Mgmt-Eth
 Configuration:
  Port admin:             Up
  Speed-duplex:           Auto
  Capabilities:           10M half, 10M full, 100M half, 100M full, TX/RX pause
 Current status:
  Link status:            Up
  Operation speed-duplex: 100M full
  Flow-control:           Disabled

DM4000(config-if-mgmt-eth)#show running-config
Building configuration...
!
! Board models in this configuration:
! Unit 1: ETH24GX H Series+L3
!
hostname DM4000
!
  • 1
    I believe you patch cords are faulty. Could you please use a guaranteed working Cat5e patch cord and report your experience with that? – Peter Zhabin Oct 12 '16 at 22:46
  • I used! Two of these 3 cables I had just opened from the plastic bag that came other network gear. I have a cable test and all of them were perfect! I tried all 4 computers with all 3 cables, they all work on 1 and 3 and don't on 2 and 4. – tvortiz Oct 12 '16 at 22:54
  • 1
    Now could you confirm that these 2 and 4 could connect to some other gigabit-capable switch with these patch cords, and also post the current configuration of DM4000 (as an edit to your question)? – Peter Zhabin Oct 12 '16 at 23:01
  • 1
    What line card are you trying to connect to? ETH24GX? ETH24GXH? – David Schwartz Oct 12 '16 at 23:13
  • 1
    Wait. Are you trying to connect to the management port and having trouble? Is your question only about connecting to the management port? – David Schwartz Oct 12 '16 at 23:14
0

My bet is that the management port doesn't have auto-MDIX. If these computers also don't have auto-MDIX, you'll need a crossover cable to connect the two interfaces.

The port jacks are switch ports and are meant to connect to a device. The management jack is a device and is meant to connect to a switch port. Connecting a device to a device will only work if at least one device has auto-MDIX. Most devices do, but it seems you may have found some that don't.

  • It make sense! But the switch has MDIX, at least I think so. I could't find how to display the current configuration. But was able to set up. Under "config-if-mgmt-eth" has options to set up mdix in mode "normal" and "force-auto". I tried both and still couldn't get a link. I unfortunately don't have a crossover cable, but I'll try to find one and test it. – tvortiz Oct 13 '16 at 20:27
  • The switch ports probably habe auto-MDIX.. But you're not connecting to the switch, you're connecting to the management interface. The management interface is probably a "dumb" device. – David Schwartz Oct 13 '16 at 20:29
  • I thought that the MDIX configuration was to the management interface, but if it is to the switch then that make complete sense why is not working! Well, I'll try with a crossover cable but thank you!!! – tvortiz Oct 13 '16 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.