6

Hypervisor:

VMWare ESXI 6 update 2

Original guest: Windows Server 2012 R2 Core

New: Windows Server 2016

Loaded the ISO in the guest and typed the following command:

d:\
setup.exe /auto upgrade /compat ignorewarning /DynamicUpdate enable

Notice use of /compat ignorewarning

Notice that adding /quiet does NOT work, there's no window (duh...), and there's no setup.exe running. Waiting 15 minutes and rebooting does not trigger an installation.

I then put in product key and set Windows Server 2016 w/o the Desktop Experience.

Windows setup starts, but in the end I'm greeted with a blank window.

enter image description here

Any way to get around that?

  • All the examples online for /compat scanonly /compat ignorewarning also have the /Quiet option. Maybe try adding that? – Mass Nerder Oct 13 '16 at 21:23
  • @MassNerder I've updated the question. Thanks, but that doesn't work. – Snake Oct 13 '16 at 22:09
  • Do you want to perform an upgradeor check for upgradecompatibility? The scan only switch performs a scan, only. ScanOnly: Windows Setup runs through compatibility scans, and then exits (without completing the installation) with an exit code to indicate if any compatibility concerns are present. Setup will return 0xC1900210 if no concerns are found. Setup will return 0xC1900208 if compatibility concerns are found. msdn.microsoft.com/en-us/windows/hardware/commercialize/… – Mass Nerder Oct 13 '16 at 22:25
  • Killing /compat scanonly doesn't work either. But you're right, removing from the question. – Snake Oct 13 '16 at 22:59
  • This is same issue as I reported also, I am trying to install Hyper-V Server 2016 though. This is definitely a issue in core install only as GUI install works fine. superuser.com/questions/1134633/… – Mayank Oct 14 '16 at 18:44
1

I finally found the solution.

In my case I had to stop all the running VM's before starting the setup and that did the trick.

| improve this answer | |
  • That's a nice solution for the Hypervisor, but in my case I am running them in ESXi, and my machines are guests, not hosts. – Snake Oct 25 '16 at 20:45
  • @CSharpFan just run the setup with /copylogs "path_to_log" flag and see the log files for errors. Resolve the errors and then try again. – Mayank Oct 25 '16 at 21:04
0

For me what stopped my install, was the vmware video card adapter being apparently incompatible with windows 10. There is an HTML file in the panther directory on the machine (/c$/$WINDOWS.~BT/Sources/Panther/ActionableReport.html) where it displays the error "this device isn't compatible in windows 10. contact the manufacturer for more info" and "VMware SVGA 3d (you'll have a problem with your display in windows 10)".

Vmware svga 3d error

I guess server core does not have the ability to display html files, and this causes the blank blue window like above from the OP.

It was fixed by re running setup.exe as "setup.exe /compat ignorewarning", after mounting the datastore ISO. This allows the install to complete in my case and bypass the vmware error. Note also that you need to have a slash before the ignorewarning command.

Check the panther directory for logs to as exactly why the install fails if you have a similar problem. This particular bug has been around on search engines since 2015, but mostly seemed to affect people who were trying to upgrade windows 10. Hard to believe it is still a bug, as pretty much everyone would be using vmware, its not some fly by night company or driver.

Another solution i saw mentioned is to change the video driver to generic microsoft VGA adapter, which apparently fixed it too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.