3

I've tried twice to upgrade my machine from 2012R2 to 2016 RTM. Both times it failed with message

0x800F0830 - 0x20003 Windows Server 2016 the installation failed in the SAFE_OS phase with an error during INSTALL_UPDATES operation

I've already tried the those

  • Use the sfc.exe to find if some errors and then repair missing or corrupted system files.

  • Run dism.exe /online /cleanup-image /scanhealth and dism.exe /online /cleanup-image /restorehealth.

Can't actually try ( IT department )

  • Disable the Anti-virus software from your system if you have any.

What do I miss?

Thanks

1

I've managed to upgrade without any further problems a long the way by doing this things:

  • Don't install updates when asked about in the setup step
  • Pulled the LAN cable after the setup prepared the machine and restarted for the first time.

I can't really recommend this solution based on facts. But in my case it did work flawlessly without any issues after the upgrade.

| improve this answer | |
  • 1
    Worked without disconnecting the LAN, I also cleaned-up the old C:\$WINDOWS.~BT setup cache before starting setup without updates. Thanks! – Tony Wall Oct 26 '16 at 14:17
1

Choosing not to install updates at the beginning of the process and unplugging the unplugging the Ethernet also worked for me to get around this. Hallelujah!

| improve this answer | |
0

Actually this error is quite often caused by lack of free space on your system drive. As you are doing in-place upgrade this process tries to create Windows.old folder for you, and possibly download and install updates. Make sure that you have enough of free space or try to decline download and install updates if wizard asks you about this. As per MSFT documentation: "Be aware that 32 GB should be considered an absolute minimum value for successful installation." (this is bare minimum space for clean install, in-place upgrade may require more space).

| improve this answer | |
  • I've got 65 GB out of 112 GB free. Guess I'll have to wait 'til Microsoft fixed the issue based on the telemetry they receive. – Chris Richner Oct 17 '16 at 6:20
  • I'm using the Storage Pool feature. What happens to this storage pool in case I'm doing a clean install instead of the in-place upgrade? – Chris Richner Oct 17 '16 at 6:22
  • 1
    It is difficult to say, during in place upgrades from 2012 to 2012 R2 some people report pool entering into "Read-only by user action" state with some corrective actions required - see this: richardjgreen.net/… – Mikhail Oct 17 '16 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.