1

elders of t3h interwebz! i seek your wisdom for a rather strange matter...

i am working on a case: a small network involving a Window Server 2012 R2 machine configured as a router, RADIUS server for wireless and also used for general network storage.

the network goes: Cisco router > server > wireless AP & computer

the server has 3 NIC's:

  • mainboard Realtek Gbit controller - connected to wireless AP > other wireless devices
  • PCIE Intel ET dualport adapter:
    • Port 1 - connected to desktop pc
    • Port 2 - connected to router

the network is not a domain, and technically the whole setup works fine; hosts are talking to the server, server monitors all connections, everyone has internet and no latency or dropout problems...

the issue here is: the throughput.

the premises has ADSL2+ that, on speed tests i did on my laptop with a straight connection to the router, reaches 20Mbps download (router reports line at 22Mbps). but the server is only getting 15Mbps at best, and so do all subsequent connections that run through the server.

at first i thought this could be a driver issue, so did the usual, no help. then i thought it could be hardware, and tried changing to different NICs for the router connection, still no good. always getting 14~15.

also tried disabling flow control, interrupt mod, power saving features, TCP RWIN autotuning and SMB signing, and checked offloading and RSS options, also increased the transmit and receive buffers... none of them helped.

i am a little out of ideas at this stage, there seems to be some sort of bandwidth control throttling the connection, but i cannot identify what and why ><

inputs and comments much appreciated ^^ much <3 and thanks!

  • removed qos from the nic? – yagmoth555 Oct 16 '16 at 13:21
  • did that too as well as ipv6 (which they don't use)... – Verna Mazanec Oct 16 '16 at 14:34
0

Problem was finally identified, it was driver issue after all...

while my go-to troubleshooting steps usually involve installing the latest official driver release, in this case i overlooked the detail of checking the currently installed driver version first before i blindly did an install (server already had the latest version).

downgraded from official Intel release v21.0 back to v20.7.1, now getting over 19Mbps download stable.

reading release note this caught my attention:

" - Intel(R) I/OAT (Intel(R) I/O Acceleration Technology / Intel(R) QuickData Technology) and Intel(R) AMT (Intel(R) Active Management Technology) features are no longer supported "

not sure whether this was the culprit or was it something else... but at least for the time being the issue is resolved.

sorry for wasting time ><

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.