1

I am trying to install PHP 7 from REMI repo, I managed to install it but when I try to issue command:

yum install php70

I get error

Error: Package: php70-php-cli-7.0.12-2.el7.remi.x86_64 (remi-safe)
           Requires: libc.so.6(GLIBC_2.15)(64bit)

I tried to look into installing GLIBC_2.15 on CentOS 6.8 but mostly found that it is not recommended. Is there any workaround or better way to install php7?

1
  • 2
    Dont mix and match packages and repos for el6 and el7.
    – user143703
    Oct 17 '16 at 14:36
4

You are obviously trying to install a EL-7 package on an EL-6 distro.

  • Remove the remi-release package
  • install the correct version
  • yum clean metadata

And PHP 7 is also available for EL-6 in my repo.

Reminder: follow the Wizard instructions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.