1

Our environment has 3 servers. One running server 2008 standard. One running 2008 R2 hosting exchange 2010 and a new 2016 standard.

Our old 2008 standard which was the DC and GC has become unreliable so we decided to migrate to 2016. We installed server 2016, made it an additional DC and GC, installed DNS, DHCP and transferred all of the FSMO roles from 2008 to it. Everything is working great except Exchange.

If we power down the old 2008 server and boot up the 2008 r2 hosting exchange it will just sit there at "applying computer settings" forever. We have to reconnect the old server to the network for us to be able to log in on the exchange machine. Once we can log in the logs say that it couldn't find the old DC.

I have tried setting a static DC and GC in exchange to our new 2016 server, also set the DNS server to use the new server however it still wont work.

Currently in the logs I am getting event ID 2080 which says that it found the new DC. followed by another event ID 2114 (DSC_E_NO_SUITABLE_CDC)

I have no idea what is going on, is there something I am missing?

Any help would really be appreciated.

  • Is the domain function level 2008 on 2016? did you look at jasonshave.blogspot.com/2010/04/… – Jacob Evans Oct 18 '16 at 2:00
  • Does your Exchange Server meet the supportability requirements? Is the new DC also a DNS server for the domain? Is Exchange configured to use the new DC for either primary or secondary DNS? - technet.microsoft.com/en-us/library/ff728623(v=exchg.150).aspx – joeqwerty Oct 18 '16 at 2:17
  • The domain functional level is 2003 on both DC's I checked that article and looked into the group policy and it appears to be correct. The new DC is a DNS server for the domain. Exchange is configured to use it as primary. after disabling ipv6 and then flushing the dns and re-enabling it, event 2080 now says that it can find the new DC. event 2114 still persists. – Kyle Vaughan Oct 18 '16 at 2:42
  • Specifically is your Exchange server at SP3 RU5 level? – joeqwerty Oct 18 '16 at 3:06
  • I ran DCDIAG and there are definitely some errors. Would a pastebin of the output help here? Also my exchange version is 14.3 build 123.4 – Kyle Vaughan Oct 18 '16 at 3:47
1

Well thank you for your help but I figured it out after a lot of digging and persistence.

It turns out that these problems were a symptom of a more serious problem.  I noticed on the original DC under file replication that there were SYSVOL JOURN WRAP errors. After doing some research I used the automatic restore registry fix that can be found here.

http://www.squidworks.net/2011/09/ntfrs-journal-wrap-errors-detected-on-domain-controller/

as well as the Burflags fix found here.

http://www.vtechie.com/2013/09/resolving-sysvol-jrnlwraperror-in.html

After it replicated everything started to work correctly.

So in a nut shell I guess even though Active directory was showing the new server as a DC and GC, it wasn't truly a DC / GC until those files replicated and thus exchange would not recognize it as one.

Hope this helps anyone else with similar problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.