4

Centos 6.8 Postfix 2.6.6

I still am having problems with Postgrey greylisting. I forgot my Dropbox password so I followed the know procedure. Dropbox sent me a mail to change it. Postgrey is continuously rejecting dropbox retries.

In my maillog each 5/6 minutes I see dropbox rejections, "reason=new"

I guess this is because sender's IP changes. After 4/5 tries dropbox server stops retries.

How can this be fixed apart of manually add sender in whitelist?

Edit 1: I added "dropbox.com" to /etc/postfix/postgrey_whitelist_clients.local, restarted Postfix but sender=01000157d7ee0e57-3626bd2e-5464-4efc-b36b-a61d9df644d2-000000@email.dropbox.com is rejected (sender's "name" changes every try)

Edit 2:

Oct 18 11:30:36 host postgrey[1813]: action=greylist, reason=new, client_name=a10-6.smtp-out.amazonses.com, client_address=54.240.10.6, sender=01000157d7ee0e57-3626bd2e-5464-4efc-b36b-a61d9df644d2-000000@email.dropbox.com, recipient=d@s

Oct 18 11:30:36 host postfix/smtpd[4306]: NOQUEUE: reject: RCPT from a10-6.smtp-out.amazonses.com[54.240.10.6]: 450 4.2.0 : Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/s.html; from=<01000157d7ee0e57-3626bd2e-5464-4efc-b36b-a61d9df644d2-000000@email.dropbox.com> to= proto=ESMTP helo=

Edit 3: After hours one of rejected IPs was used again so mail was delivered

Oct 18 14:03:39 host postgrey[1813]: action=pass, reason=triplet found, delay=10532, client_name=a27-148.smtp-out.us-west-2.amazonses.com, client_address=54.240.27.148, sender=01010157d8133997-c0c68e0b-a976-4319-9e67-0f18785a6bbe-000000@email.dropbox.com, recipient=d@s

Oct 18 14:03:39 host opendkim[1496]: 004561CA0888: message has signatures from dropbox.com, amazonses.com

Oct 18 14:03:40 host postfix/qmgr[12510]: 004561CA0888: from=<01010157d8133997-c0c68e0b-a976-4319-9e67-0f18785a6bbe-000000@email.dropbox.com>, size=6972, nrcpt=1 (queue active)

  • Is there a DNSBL is blocking it, or is it the "first try from new IP fail/delay" mechanism? In my case it was SORBS. I commented out the dnsbl.sorbs.net line in /etc/postfix/main.cf and magically postscreen worked better with IP pools from gmail, MSN, dropbox, etc. reddit.com/r/sysadmin/comments/4acuqf/… – dhaupin Oct 18 '16 at 14:49
  • @dhaupin I don't have any line containing dnsb.sorbs.net in my main.cf. It should be IPs issue. I added some info about it – dstonek Oct 18 '16 at 17:45
  • 1
    Same thing here. Dropbox tries to deliver mail, but every time from different IP, so it's obvious it must fail. Looks like an ultimate failure of someone configuring mail delivery for them. – wrzasa Dec 19 '16 at 18:43
  • Have you tried to add dropbox.com to /etc/postfix/postgrey_whitelist_clients.local ? – dstonek Jan 3 '17 at 1:05
0

Try this setting in /etc/postfix/postgrey_whitelist_clients.local or /etc/postfix/postgrey_whitelist_clients

# Clients that should not be greylisted.  See postgrey(8)
# use regexp to match the sending hostname for whitelisting
/^a*-*\.smtp-out\.amazonses\.com$/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.