1

So here is an interesting problem. Over the past few days we have been migrating from an unreliable DC runnign server 2008 to a new DC running server 2016. We have moved ADDS, certificate services, DNS, DCHP although we ran into some bumps in the road it is all done and the old domain controller running 2008 has been demoted and the roles removed.

Now here is the interesting part.

We have Exchange 2010 running on server 2008R2 on the network which connects to the active directory. It sees the new domain controller and everything works as usual except for one thing,

If I open the EMC and then click on "mailboxes" to add and assign new mailboxes, it will instantly crash our domain controller.

The error that we get in the event log on the 2016 domain controller just before it crashes is :

Event ID: 1015 A critical system process, C:\Windows\system32\lsass.exe, failed with status code c0000005. The machine must now be restarted.

As well as

Event ID: 1000

Faulting application name: lsass.exe, version: 10.0.14393.0, time stamp: 0x57899b4c Faulting module name: msvcrt.dll, version: 7.0.14393.0, time stamp: 0x57899b47 Exception code: 0xc0000005 Fault offset: 0x000000000005c7a0 Faulting process id: 0x288 Faulting application start time: 0x01d22a5efa3470a5 Faulting application path: C:\Windows\system32\lsass.exe Faulting module path: C:\Windows\System32\msvcrt.dll Report Id: 6893cc25-892d-4f9e-a84c-9b2937f85b6e Faulting package full name: Faulting package-relative application ID:

I have no idea what is going on. Any help would be greatly appreciated.

  • Can you update the visual c++ runtime via Microsoft update ? version 7.0.14393 seem old to me – yagmoth555 Oct 20 '16 at 1:10
  • I have tried and all it had was a security update which I installed. The version is still the same and there is no change. – Kyle Vaughan Oct 20 '16 at 3:51
  • 1
    If I check from the other server, c0000005 is a memory error, is it a physical server that the ram was tested ? – yagmoth555 Oct 20 '16 at 4:02
  • No it is a virtual machine running on an HPDL380G7 host. The ram is good on the host. – Kyle Vaughan Oct 20 '16 at 4:16
  • Well thank you so much for mentioning that the specific error is a memory error. It got me thinking, both servers are virtual machines on the same host. If this was a memory error the only way i could see clicking something in exchange totally crashing the domain controller is if they were sharing memory if this was in fact a memory error. So I moved exchange to a different host and it works perfectly now. No crashing when I click "mailbox" THANK YOU! – Kyle Vaughan Oct 20 '16 at 4:56
1

Not sure if anyone is still having this issue - but we increased our Domain Controller's RAM from 2GB to 4GB and the issue corrected.

0

If anyone encounters the same error I am having and both exchange running on 2008 R2 and domain controller running on server 2016 are VMware virtual machines residing on the same host, move one virtual machine to a different host and problem solved.

  • I think there's more to the issue than just memory error. I've been having the same issue since installing W2016 servers. We do have exchange on W2008R2 but not on the same host, however both are at the same site (and the 2016 server is the default AD server for exchange). – Linwood Sep 25 '17 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.