0

I've Wordpress sites hosted in Rackspace server. I'm able able to connect to the server via ssh through port 22. But when i try to connect to the server via FTP through port 21, i'm getting error

Response: 500 OOPS: vsftpd: refusing to run with writable root inside chroot()

Error:Critical error

Error:Could not connect to server

I've opened port 21 inside the server. The site is hosted in RACKSPACE Server with Ubuntu 14.04

Installed vsftp in the server. And i'm using root user credentials for the FTP connection.

I even tried creating a new user for the same. But i'm getting the same error.

I used Filezila to connect to the server.Do i need to configure anything else in the server.

marked as duplicate by Steffen Ullrich, mdpc, HBruijn Oct 22 '16 at 7:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is this in Google Cloud? If yes, did you create a firewall rule under menu "Compute", "Networking"? – Marcelo Rodrigues Oct 20 '16 at 11:27
  • Nop its in Rackspace server – Nijo Oct 20 '16 at 11:58
1

This is copy pasta from - HERE He goes into more detail, but basically the solution should just be this below.

The problem is that your users root directory is writable, which isn’t allowed when using chroot restrictions in the new update.

in your vsftpd config file add this at the bottom

allow_writeable_chroot=YES

Not the answer you're looking for? Browse other questions tagged or ask your own question.